BT in LE settings crash UI on rpi 4

  • I'm on LibreELEC 9.1.501 using an RPi 4. When trying to access the bluetooth settings in the LE settings addon the UI crashes in such a way that I can still move around the left pane but nothing on the right side changes. I can't get back to any other menu and have to reboot using SSH. I think this is the relevant lines from my crash log. Anyone else with this issue?

    Code
    1. 2019-10-08 11:25:39.249 T:2817131376 ERROR: ## LibreELEC Addon ## oe::load_config ## ERROR: (IOError('file() constructor not accessible in restricted mode',))
    2. 2019-10-08 11:25:39.250 T:2817131376 ERROR: Traceback (most recent call last):
    3. File "/var/lib/jenkins/LE/build5/workspace/RPi4/build.LibreELEC-RPi4.arm-9.1.501/LibreELEC-settings-f59dcc824fd8fe5b79c0a709a0c70676cc9ab3b1/.install_pkg/usr/share/kodi/addons/service.libreelec.settings/oe.py", line 553, in load_config
    4. IOError: file() constructor not accessible in restricted mode
    5. 2019-10-08 11:25:39.250 T:2817131376 ERROR: ## LibreELEC Addon ## oe::read_setting ## ERROR: (AttributeError("'NoneType' object has no attribute 'getElementsByTagName'",))
    6. 2019-10-08 11:25:39.251 T:2817131376 ERROR: Traceback (most recent call last):
    7. File "/var/lib/jenkins/LE/build5/workspace/RPi4/build.LibreELEC-RPi4.arm-9.1.501/LibreELEC-settings-f59dcc824fd8fe5b79c0a709a0c70676cc9ab3b1/.install_pkg/usr/share/kodi/addons/service.libreelec.settings/oe.py", line 635, in read_setting
    8. AttributeError: 'NoneType' object has no attribute 'getElementsByTagName'

    EDIT: I found the culprit. Disabling the addon "Bluetooth Audio Device Changer" fixed the issue. Only issue then, is that I need to fool a lot around the settings menu when I want to use my BT headset, but I can live with that for now. If anybody else have this issue this is the work around.

    Edited once, last by jackiass ().