RPI 3B+ & RPI 4B: Internal WIFI not showing up!

  • So I got a RPI 3B+ with LE 9.0.2 and one RPI 4B also with LE 9.1.002 Alpha running.

    Both devices do not show the option to enable WIFI. System settings only offer to activate the wired connection.


    Plugging in an USB WIFI dongle does work and lets me connect to the network.

    However it only scans for networks over the dongle (wlan0).

    The connection settings page only lists wlan0. It used to show all found networks twice because KODI scanned using wlan0 (internal) and wlan1 (dongle).


    Is anything like this a known issue?

    It used to work with previous versions of LE.

    Edited once, last by igl322 ().

  • I have the same issue. Just switched over from RPI3B+ to RPi4B w/ 9.1 and the 2.4 and 5.0 show for a moment, I can connect to the 2.4 but if I try to connect to the 5.0 it will glitch and ALL wifi connections vanish.

    Reboot and they will sometimes appear. If the wifi is working and I shitdown/reboot, I have to re-enter wifi details manually (thats if it can detect the wifi at all).

  • i just got my RPi4B and tried it with the libreelec avaiable and wifi detects when i search for it initially, but after restart it doesn't autoconnect anymore. even deactivating and activating don't work.

    i tried setting it to wait for network on restart and set up 30sec. even then i couldn't connect to any devices in my LAN or the internet anymore after a restart.


    edit: ok. i discovered, that: when i shutdown raspberry over the poweroff in kodi and start it again it often finds the wifi. if i close it the hard way it doesn,t

    Edited 2 times, last by sil_el_mot ().

  • My LibreELEC configurator works perfectly, and i can get wired ethernet. Wireless is detecting my 2.4GHz network but not my 5GhHz. Router is about 10 feet from RPi 4. Ordered another unit to see because I'm testing to see if i need to send this one back.