S805x build (lafrite)

  • This is a bit of a specific question, but figured I'd try asking.


    There has recently been support committed for the s805x chip, as used in the La Frite board. There have been people who had built out of master (with a slight tweak to `scripts/uboot_helper`) which successfully runs on the board.


    I've tried both their build, and my own, with various settings and I'm not getting any video out of the system at all, past the uboot loading - once libreelec takes over the screen goes blank. The install works otherwise ok - I can ssh in and use the web interface at 8080. The web interface offers the option of changing screen resolution, but only offers 1280x720, which isn't the only size offered by the connected display - as reported by edid-decode.


    So, my question: is there any additional things I can do to try and narrow down where it's going wrong for me? The only potential difference I've been able to isolate between my board and one known to work is that they have 1G RAM and I'm on 512M - but I wouldn't expect that to yield a lack of video.


    I've tried turning some debugging on, but it's not being recorded anywhere that's telling me anything - is it essential that I get access to the serial output to see some of that?



    J,