How helpful will this be to getting LibreELEC on allwinner android boxes?

  • Dears,


    I own "Tevii p500" which is a "Sunvell Q+" and it's same as "Tanix x6", i booted from "SD card" but output on my TV is a black screen, so i connected to it's UART and i can confirm kernel booting till "init" start, then no message, so what is wrong, kindly find the UART dump in attachments.

    Files

    • Q+.txt

      (19.06 kB, downloaded 17 times, last: )
  • RedFighterCZ sorry for late response. Can you confirm this is still the case with latest nightly image, e.g. LibreELEC-H6.arm-9.80-devel-20200426012033-38764c8-tanix-tx6.img.gz ? I tested it and it seems to work correctly.

    Dear jernej,


    I tried with one you mentioned "LibreELEC-H6.arm-9.80-devel-20200426012033-38764c8-tanix-tx6.img.gz", but still same thing as "LibreELEC-H6.arm-9.80-nightly-20200601-83a3b6d-tanix-tx6.img.gz", black screen output, but UART confirm kernel boot, kindly find the UART dump in attachments.

    Files

    • Q+_devel.txt

      (19.09 kB, downloaded 10 times, last: )
    • Q+_nightly.txt

      (19.13 kB, downloaded 14 times, last: )
  • genidy.m please do not cross-post the same information to multiple threads. If you make one post it will be seen by the developers and mods. Multi-posting is annoying and will normally decrease (not increase) the chances of someone taking an interest in your problem.

  • genidy.m No error can be found in logs, so I can't do anything. If you can find android image for that box (either full image or update file), I can check few things, but no promises. Device tree file from live system would also work but I can't guide you since every Android is a bit different.

  • genidy.m please do not cross-post the same information to multiple threads. If you make one post it will be seen by the developers and mods. Multi-posting is annoying and will normally decrease (not increase) the chances of someone taking an interest in your problem.

    Dear Chewitt,


    Noted with thanks.

    Sorry for that, i thought because there is more than one threads about same "SOC" it will be useful to put the UART dump, sorry i didn't mean to cross-posting, again i am sorry.

  • genidy.m No error can be found in logs, so I can't do anything. If you can find android image for that box (either full image or update file), I can check few things, but no promises. Device tree file from live system would also work but I can't guide you since every Android is a bit different.

    Dear jernej,


    Thanks for your quick reply, yes i have the the full official android image, i used because i bricked it after i installed "SuperSU," so i flashed it and working very well with android.

    Tevii P500 is a rebrand for "sunvell Q+".

    You can find the box and some picture for the SOC here "https://forum.freaktab.com/forum/frealktab-team-reviews/tv-boxes/770801-sunvell-q-plus-allwinner-h6-tv-box-review".

    You can download the android image from here "https://mega.nz/file/g8VmiQxB#ZS3nMlPlHpBmNu8IGJYXbXt9fRPhUDBG6VU5h46%20fGsI"
    also i can upload it to my google drive if there issue in the mentioned link.


    Thanks again.

  • Sorry to say, but configuration for display is same, so it should work. Can you test with different monitor and different HDMI cable?

  • Sorry to say, but configuration for display is same, so it should work. Can you test with different monitor and different HDMI cable?

    Dear Jernej,


    I tried different "HDMI" cables, another TV also same results, but while i "power on" and "power off" i noticed there are a new messages about "mmc1", but i saw this message only after restarting more than once, some times it comes some times not, kindly find the UART dump in attachments.

    Files

    • Q+_new.txt

      (19.22 kB, downloaded 18 times, last: )
    • Q+_new1.txt

      (19.34 kB, downloaded 14 times, last: )
  • Nothing in the logs... This reminds me on Eachlink box, where no error is logged but HDMI output also doesn't work. Unless I get such unit, I can't do anything.

  • Nothing in the logs... This reminds me on Eachlink box, where no error is logged but HDMI output also doesn't work. Unless I get such unit, I can't do anything.

    Dear Jernej,


    Thanks four your support, i will follow forum in case of any new, Thanks again.

  • Nothing in the logs... This reminds me on Eachlink box, where no error is logged but HDMI output also doesn't work. Unless I get such unit, I can't do anything.

    Dear Jernej,


    I tried "Armbian" and found that "HDMI" output working, then tried unofficial build of "Libreelec" and found some success that screen appeared for one second then black screen, then reversed console entries to start with "console=tty1 console=ttyS0,115200" instead of "console=ttyS0,115200 console=tty1" and "HDMI" output working well, then i tried with official one here and it is working too, i can see now the output on TV, also if i removing "console=ttyS0,115200" and keeping "console=tty1" screen goes black again, so two console entries must exist and reversed, moreover i facing a new issue that it stuck at "mmc1: new DDR MMC card at address 0001", kodi not started.

    Files

    • Q+_hdmi.txt

      (18.75 kB, downloaded 16 times, last: )
  • Dear Jernej,


    Booting stuck because it didn't recognize the "boot and disk" UUID entry also same thing in "unofficial build of libreelec uses label instead of uuid", so i replaced those entry to use device logic name like this "APPEND boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 console=tty1 console=ttyS0,115200" and now worked very well, i don't know why it can't handle label or uuid, but for now it working well, i will play with it to discover it, finally i really thank you for all your support and thanks all "Libreelec" guys for that OS, it working really very fast, beautiful interface, i like it very much than ugly android os.


    Tevii P500 (Sunvell Q+)

    -------------------------------

    *OS booting very fast

    *HDMI video & audio working very well

    *Ethernet working very well

    *kore remote control working very well, i used to configure libreelec insted of mouse as (booting libreelec with attached lan and kore zeroconf worked very well), really good.

    *Wireless not recognized ('ifconfig -a' showed no interface, driver missing or some thing else)


    Thanks again to all "Libreelec" guys.

    Files

    • Q+.txt

      (25.19 kB, downloaded 15 times, last: )

    Edited once, last by genidy.m ().

  • Dears,


    I am facing "CPU" overheat issue on Q+ (Tanix-TX6), at idle, on android temperature average 59C, on Libreelec temperature raised very fast to reach 126C, then the box restarted because overheating, dmesg show error with cpufreq "sun50i-cpufreq-nvmem: probe of sun50i-cpufreq-nvmem failed with error -2", kindly find the full dmesg log in attachments.

    Files

    • dmesg.txt

      (27.08 kB, downloaded 10 times, last: )
  • Dears,


    I am facing "CPU" overheat issue on Q+ (Tanix-TX6), at idle, on android temperature average 59C, on Libreelec temperature raised very fast to reach 126C, then the box restarted because overheating, dmesg show error with cpufreq "sun50i-cpufreq-nvmem: probe of sun50i-cpufreq-nvmem failed with error -2", kindly find the full dmesg log in attachments.

    Dears,


    I used a "DTB" file from armbian, and now "cpufreq-dt" driver loaded and i can control scaling governor, still overheat exist.

  • Dear Jernej,


    I am facing issue with installing "Libreelec" into emmc, as dd command hang, also parted hang, any command access the emmc will hang, and that explain to me why "Libreelec" stuck at first time and only booted with "APPEND boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2", i think sunvell Q+ (Tevii P500) affected by H6 "HS-DDR" issue, that fixed by your patch i found in "Armbian" forum, so is it already included in "Libreelec" then i facing some thing else, or not included and must i recompile "Libreelec" kernel patched with it, Thanks.

    Files

    • emmc.patch.txt

      (979 Byte, downloaded 11 times, last: )
  • I already explained in one topic (don't remember which) why this emmc hack will never come back. In short, someone must figure out what is really wrong. Secondly, there is no official support for Q+ and that's why I won't introduce hacks for it.