Rpi3 low audio via analogue output

  • Hi all hoping someone can help me here.

    I have a rpi3 b and have recently started using a Logitech 2.1 speaker set with it as modern TVs seem to have poor sound these days.


    The Logitech speakers are a set I use to use with my pc and they are loud using the computer with them.


    But plugging them into my pi using LibreELEC 9.0.2 they seem to be really quiet.


    I can confirm this as when I thought to myself "I'm sure these were alot louder on my computer" I then took the cable out and plugged it into my phone, played the same video from my Nas on my phone and boom they were a hell of a lot louder.


    I've turned the volume upto 100% with Kodi GUI but they are still no where as loud as they are plugged into other devices.


    Any help would be great.

    Thanks

  • It sounds like the Rpi3 has a lower than normal line level output. What is the volume like when using an hdmi cable directly to your tv ?

  • When using the hdmi cable directly to my TV the volume is fine through my TVs speakers.


    Its just the analogue out that appears to have low volume but when I say low volume it really is low! I have to turn it up to full volume for it to be ok to listen, if I plug the Logitech system into other devices I get approx double the volume.


    Thanks

  • Go to "Settings -> System -> Audio -> Audio output device" and select "PI: HDMI and Analogue".

    Proved by myself. :)

    Beast Mode

  • Go to "Settings -> System -> Audio -> Audio output device" and select "PI: HDMI and Analogue".

    Proved by myself. :)

    My pi is already on this setting.

    Ive tried analogue only and Pi: HDMI and analogue.


    Both have no difference in volume for the analogue output, I still get low volume using both settings.


    Also I believe this to be specific to LibreELEC.


    Reason why is because I have another memory card with recalbox. Using that SD card on the same pI, going to settings changing the output to analogue and setting the volume to 100% makes recalbox almost twice as loud as LibreELEC.

    Its just as loud on recalbox as it is plugged into my computer or phone, just how I would expect it to work.

  • OK, on my headphones LE is loud enough. I have set the audio channels to 2.0. Maybe it affects analogue audio, too.

    Beast Mode

  • Ok, so my audio is already on 2.0


    The audio cable is pushed in all the way.


    Still the audio output volume is low on LibreELEC.


    Like I say output volume over analogue works fine on recalbox and is just as loud as expected.

    It's almost like something somewhere is not 100% behind Kodi.


    Does Kodi GUI adjust volume just for Kodi or does it adjust the volume for the line out.


    For example running Kodi on my home computer, if I set my output to say 50% in the bottom right corner of the task bar then adjusted the volume within Kodi would it adjust the volume for the audio device or just the volume within Kodi interface.


    Reason I ask this is this is what I believe to be the problem, purely because it works fine on recalbox.


    But I don't have enough knowledge to dig into LibreELEC to find out.


    Thanks

  • Press that plug in as far as you can till it clicks.

    Are you sure it's not a driver issue and audio outputs are working and recognized properly?


    ssh to your pi

    Code
    1. aplay -l

    check if device 0 analog is available..


    If you get the error no sound card detected (not sure if it's a bug or something changed in LE9) add this line to config.txt

    Code
    1. dtparam=audio=on

    Restart and go back to LE menu where you change audio output...now you can see more options to choose from namely ALSA default driver analog/hdmi or both


    Hope this helps you in some way..

  • Well I can honestly say I've tried all the above suggestions and none work.

    No matter what I try LibreELEC has low volume over line out/analogue.

  • Well I can honestly say I've tried all the above suggestions and none work.

    No matter what I try LibreELEC has low volume over line out/analogue.

    Did you try the USB adapter in post #9 above ?

  • I found the solution to edit analogue volume. :)

    Edit the file /STORAGE/.kodi/userdata/guisettings.xml.

    Change the XML content of "audio" (bottom of the file) like this to get max. analogue volume:

    Code
    1. <audio>
    2.     <mute>false</mute>
    3.     <fvolumelevel>1.000000</fvolumelevel>
    4. </audio>

    Beast Mode

  • Did you try the USB adapter in post #9 above ?

    As the pi already has a analogue out i do not see how this would solve my problem unless the analogue out was broken.


    As the analogue out works perfect with recalbox that proves the analogue out on my pi is not broken.


    Also my pi is in a mini snes case and one of them adapters sticking out the front would ruin the aesthetics of the case.


    Thanks

  • I found the solution to edit analogue volume. :)

    Edit the file /STORAGE/.kodi/userdata/guisettings.xml.

    Change the XML content of "audio" (bottom of the file) like this to get max. analogue volume:

    Code
    1. <audio>
    2.     <mute>false</mute>
    3.     <fvolumelevel>1.000000</fvolumelevel>
    4. </audio>

    Hi,


    having a play with this setting and i discovered all this does is change the volume of the kodi interface.


    setting it to 1.000000 only adjusts the volume to 100% within the kodi gui, setting it to 0.950000 changes the kodi gui volume to 95%


    so if i use remote to turn kodi gui volume down to 50% and then look back at the guisettings.xml the audio setting now tells me its at 0.500000


    so my conclusion is that settings is just the generic volume setting within the kodi user interface.


    As this is already 100% and i still get low volume this unfortunately does not work for me either.


    Thanks

  • so far ive only found one solution but it creates another problem.


    if i play a movie, press ok on remote then go to audio settings, there is a option called audio amplification.


    if i turn that up to around 20.0db the movies sound about the same volume as they would if plugged into either my phone or home computer.


    Perfect seems like it solved but it isnt.


    if i then decide to turn off the external speakers connected to the analogue (for example when the kids are in bed so its not to loud) and use hdmi so that it uses my internal tv speakers, the volume is then excessively loud.


    Going back to audio settings and turning the amplification back down to 0.0db is the only way to then sort this.


    So my conclusion is that libreelec is somehow sending different volume levels to both outputs, hdmi being perfect with default settings but analogue being very low.


    Like i say my conclusion comes based on the fact recalbox's volumes work as expected wether i choose analogue or hdmi.


    Im about ready to give up on this grrrrrrrrr


    Thanks

  • Thanks for the feedback. It looks like we are still dealing with master volume control, not just the analogue part.

    I've been uploaded my current RPi guisettings.xml. Give it a shot.

    Beast Mode

  • You do autostart scripting to make your case work, right? If my guisettings.xml don't work, deactivate the autostart scripting for a test run.

    Beast Mode