PI4 and 3D mvc not working

  • I am running LibreELEC-RPi4.arm-9.1.001 on a Raspberry PI 4

    I ripped a 3D Blu-Ray using makemkv and named it with 3D_MVC so Kodi would know it was 3D (which it does)

    My projector uses frame-packed 3D which, as I understand it, is alternating frames of left and right and I have shutter-type glasses.

    3D works fine if I play the Blu-Ray on my DVD player, so I know the setup is correct.

    When played by Kodi the movie is shown in 2D. When the movie starts, Kodi asks me how to play the 3D and I pick "same as source" (or something like that) but it still shows in 2D

    My projector is 4K and Kodi is set up for 4K 60hz (using the hdmi_enable_4k in config.txt)


    Not sure what else I should be checking to get the 3D to play. I do have a Kodi log for the playback but I am not sure what to be looking for in it.


    Thanks in advance.

  • Yes Pi3 builds support 3D

    Does it matter which build i use whether it's v9.0 or 9.1?


    I assume the 9.1 is the latest and preferred build, but when you go to that page the 9.0 build (middle tab) is selected by default so I don't know what the difference is.


    Thanks!

  • For anyone who wants to know, I originally installed v9.1 on the 3B+. When I ran 3D-MVC videos (possibly with all of them, but I didn't add anything but MVC to my Kodi library yet) the video would stutter/stop a lot and was not really usable.

    When i went into the update repositories and checked for LibreElec updates it said ti found one, but it was the v9.02 version, which is actually a LOWER version number. I let it "update" the system and it ran stable after that.

    I'm guessing the v9.1 series is still beta maybe?