Problems running Kodi Leia on Raspberry Pi 2 (LE 9.0.2)

  • Kodi Leia runs poorly compared to Krypton on my Raspberry Pi 2. Specifically it appears to run sluggishly when playing live TV using nextPVR. I've encountered the following problems with LE 9.0.2 (Kodi Leia 18.2):

    1. The initial problem I encountered was the screen going black when changing channels. I resolved this issue by getting rid of all overclocking code in my config.txt file.
    2. The next problem I encountered was the video skipping frames in order to maintain sync. I partially resolved this issue, but not to my satisfaction, by turning off de-interlacing under video settings.
    3. Another problem I encountered was the audio being out of sync with the video. This problem is intermittent and I have not found a permanent solution to the issue.
    4. When changing channels, the screen will freeze or go black for a good 8 seconds while the audio is playing and then suddenly jump to the video syncing with the audio.
    5. Finally I my system would crash whenever I attempted to perform time shifting. This turned out to be an issue with a setting in the nextPVR add-on.

    I've used two different methodologies to create my system files:

    (1) Clean install of LE version 9.02 using LE USB-SD Creator. After an initial setup, I restored from a backup created by the current version of LE 8.2.5.

    (2) Clean install of LE version 8.2.5 using LE USB-SD Creator. After an initial setup, I restored from a backup created by my current version of LE 8.2.5. After verifying that everything was working properly, I upgraded the system to LE version 9.0.2.

    Note: Both systems are licensed to use the Pi's hardware MPEG2 decoder.

    Has anyone else experienced similar problems running Leia on a Raspberry Pi 2 or higher?

  • I too experience video stuttering playback issues on a RPi2 with Kodi 18.x on LE 9.x with 1080i MPEG2 North American Over-The-Air TV content. The cause of the video stuttering appears to be a change in the default automatic deinterlacer to Adv(2x) in Kodi 18.x used in LE 9.0.2. On LE 8.2.5 with Kodi 17.6 the default automatic deinterlacer is Bob(2x). To work-around the issue you can manually select the deinterlacer from the in-playback kodi menu.


    For now I have chosen to stay with LE 8.2.5 on my RPi2, as described in a tutorial I wrote: Installing LibreELEC 8.2.5 with MythTV PVR Client on a Raspberry Pi 2/3/3B+


    'Hope that helps.

    Edited 2 times, last by gedakc: Add kodi versions and RPi2 ().

  • I think I have resolved my issue with Leia by eliminating the advancedsettings.xml file that was inherited from Krypton. So far, the sluggishness I was experiencing appears to have gone away. However, I'm still having a problem with the screen going black or freezing for 4 to 8 seconds when changing a channel. Has anyone else experienced this problem?

    Edited once, last by jmooremcc ().

  • I think I have resolved my issue with Leia by eliminating the advancedsettings.xml file that was inherited from Krypton. So far, the sluggishness I was experiencing appears to have gone away. However, I'm still having a problem with the screen going black or freezing for 4 to 8 seconds when changing a channel. Has anyone else experienced this problem?

    I get the black screen when I play 1080i live tv streams in pvr windowed mode...it works properly when windowed mode is disabled or change deinterlace to MMAL BOB from auto or change Kodi resolution to 720 from 1080 and leave deinterlace on auto..