Nightly images for A64, H3, H5, H6 and R40 boards

  • if we want the last release of LibreElec (9.2.1) that use kodi 18.6 where we find?

    i tried to compile it but u-boot error

    i want it for NanoPi M1

  • if we want the last release of LibreElec (9.2.1) that use kodi 18.6 where we find?

    i tried to compile it but u-boot error

    i want it for NanoPi M1

    I tried to compile LE master branch for BananaPi M2 Zero, which also is a 512MB board, should be very similar. u-boot didn't work, so I downgraded u-boot to the latest version used in Armbian instead, and applied all patches that Armbian uses. (And then I removed most of the ones that didn't relate to my device, many with *nanopi* in their name.) And that worked very well. I now have a LibreELEC image that boots fine, with lima graphics. If you want, I can upload my changes. Adding nanopi-related u-boot patches from Armbian to my changes should be trivial.


    By the way, problem for me was that video playback doesn't seem to work. (I also tried with libmali, but then I got unaccelerated video playback.) I synced with master yesterday, so maybe a new build will fix that as well. Anyway, please share your experiences, would love to hear how another *unsupported* 512MB H3 device fares.

  • I tried to compile LE master branch for BananaPi M2 Zero, which also is a 512MB board, should be very similar. u-boot didn't work, so I downgraded u-boot to the latest version used in Armbian instead, and applied all patches that Armbian uses. (And then I removed most of the ones that didn't relate to my device, many with *nanopi* in their name.) And that worked very well. I now have a LibreELEC image that boots fine, with lima graphics. If you want, I can upload my changes. Adding nanopi-related u-boot patches from Armbian to my changes should be trivial.


    By the way, problem for me was that video playback doesn't seem to work. (I also tried with libmali, but then I got unaccelerated video playback.) I synced with master yesterday, so maybe a new build will fix that as well. Anyway, please share your experiences, would love to hear how another *unsupported* 512MB H3 device fares.

    i have a RPI4B but it Was broken 2 day ago :(

    i want to use my previous board (nano pi m1) :/

    can you help me?

    can you clone libreElec repo (9.2.1 kodi18.6) in github and fix u-boot error?

    i can test it and write down the result

    thank you PJBrs

  • i have a RPI4B but it Was broken 2 day ago :(

    i want to use my previous board (nano pi m1) :/

    can you help me?

    can you clone libreElec repo (9.2.1 kodi18.6) in github and fix u-boot error?

    i can test it and write down the result

    I'll give you a couple of pointers to help you out. I've just uploaded my patches to github, they're four patches to add support for BananaPi M2 Zero. One of the patches reverts to an older u-boot. But please note that you have to adapt it to your own device. While technically my device is identical to H3, it is branded H2. You should be working on the H3 device, and change the u-boot patches for H3. And perhaps add your device to u-boot scripts (see another of my patches). My LibreELEC branch (only the last four patches):

    Commits · PJBrs/LibreELEC.tv · GitHub


    For u-boot patches, please see Armbian:

    build/patch/u-boot/u-boot-sunxi at master · armbian/build · GitHub


    If you use u-boot version 19.10 and add all above patches, then I'm pretty sure your device will boot. Barring, of course, kernel patches for NanoPi... But that's another story (to which, again, Armbian might have many answers).

  • After some time I tried the versions for H5 and H3 again. The version for H5 always has the problem of the HD check, and that for H3 is very slow in the response from the remote control. It also has some blocking problems. I downloaded an old one 9.20 for H3 and it's really lightning, but no longer has the addons. Can you find a complete 9.20? Thanks

    • Official Post

    LuRu First of all, please don't use formatting which would suggest screaming or needlessly seek attention. It's very distracting.


    Those issues you found out are exactly the difference between the boards you mentioned. There is OPi Lite 2 PR open, but it seems author lost interest (maybe requested fixes were a bit too hard...). Anyway, I don't have this board. If the PR author or someone else improve it, then I'll merge it. If not, well, bad luck.

    • Official Post

    if we want the last release of LibreElec (9.2.1) that use kodi 18.6 where we find?

    I downloaded an old one 9.20 for H3 and it's really lightning, but no longer has the addons. Can you find a complete 9.20? Thanks

    There are no 9.2 images and addons for Allwinner. First release of (semi) stable images will come with LE 10. However, 9.2 image and addons can be build from libreelec-9.2 branch, but be warned, a lot of fixes are missing, especially wrt video decoding.

  • Hello ;)


    I have a LibreElec (version from starting this week) running on an OrangePi Plus 2E (H3).

    For me everything is working great except 4k. I think it affects all codecs. On the manufacturer page it's written that only H.265 is supported, but when I remember it correctly this also affects H.264.

    On 4k there are sometimes wrong colors (blue shade) and artifacts, but it is working fluently when it gets downscaled from 4k to 1080p 25fps.


    Is there a general status how 4k is working ;) ?


    Thank you very much for this great software!


    regards mampf

  • Hi guys

    I continue to experiment with Prange PI One-plus.

    I got a normal image with sun50i-h6-pine-h64.dtb file

    But now there is no sound, no network ...


    I remind,

    There is no image with the sun50i-h6-orangepi-one-plus.dtb file, the sound is crackling.


    I need to edit the dtb file ... but the distribution does not have the "dts" utility and apt-get is disabled))

    how to edit?

    • Official Post

    Is there a general status how 4k is working ;) ?

    Last time I checked it worked perfectly for me on OrangePi Plus 2E. Anyway, your issue seems like issue in DRM driver and not in VPU driver. VPU in both cases (downscaled or not) outputs same image, but DRM driver is responsible for downscaling and outputting it on HDMI. Can you make a photo of issue?


    I need to edit the dtb file ... but the distribution does not have the "dts" utility and apt-get is disabled))

    how to edit?

    Only on your PC with programs like dtc. You can easily find tutorials with google.

  • Can you build the correct dtb for one-plus? ;))


    without sound, watching a movie is not interesting ...

    and ... listening movie without an image is boring ...))

  • syao Sorry, but I can't help you with CEC. There are no changes in Allwinner project regarding CEC since 3rd March. Maybe you can do a bisection? I don't have much time for LE ATM, except responding on the forum.

    Sorry jernej but don't get what you mean with bisection. Anyway, I tried to update nightly 20200304 (CEC was working fine) with latest tar file available (20200329) and CEC does not work anymore (affer a couple of key press TV warns me that anynet device has disconnected).

    From SSH then I stopped kodi and launched cec-client from command line: no problems, CEC is working fine, tried pressing some keys for about a minute and all events are shown in the debug log.

    Then I killed cec-client, restarted kodi and turned on logging for libCEC: again the problem is that after a couple key press events it disconnects. If then I search anynet devices from TV menu, sometimes I can reconnect but again it works only for a brief time.

    I couln't find any clue in debug log, anyway I'll post it in attachment.


    Regards

    Christian

    kodi.log

    Edited once, last by syao ().

    • Official Post

    Sorry jernej but don't get what you mean with bisection.

    A beginner's guide to GIT BISECT - The process of elimination | Metal Toad


    CEC issues are not easy to find and currently I have no time to even start working on one. Most of the time it also depends on the TV, which of course is not the same as my own. With bisection (tutorial above) you'll find exact commit which is responsible for the issue. This is time consuming due to image building and testing but more or less only hope.

  • if i boot sun50i-h6-pine-h64.dtb

    there is no sound...

    video exelent...


    Now I (you, all)need to take a video from sun50i-h6-pine64.dtb

    and put it in sun50i-h6-orangepi-one-plus.dtb

    and universal happiness will come ...

    may be.. ))