Nightly images for A64, H3, H5, H6 and R40 boards

  • Hi,

    I have a nanopi M1. LibreELEC has been working well up until recently, but recent nightly builds do not boot. Neither after an update, nor from a fresh install.

    I think I have tracked the problem down to the update to u-boot: update to v2020.01 (commit u-boot: update to v2020.01 · LibreELEC/[email protected] · GitHub). A build from u-boot: use upstream patches for Orange Pi 3 (the commit prior to the u-boot 2020.01 commit) builds and boots just fine - as far as I can tell, this is the last one that boots.

    Thoughts, anyone?

  • I thought someone might ask for that :/ Sadly, I'm not sure if I have a serial-USB around here anywhere. I'll investigate.

  • Have not managed to find a usb-serial yet, but I think I have a spare arduino in a box somewhere - I'll use that if I find it.

    In the meantime, I can confirm the following builds an image that boots (from fresh install and from update):

    git checkout master
    git pull
    git revert 4c80f82f21028b08b6a2d10201eb111baae48909
    PROJECT=Allwinner ARCH=arm DEVICE=H3 UBOOT_SYSTEM=nanopi-m1 make image

    Maybe dejan_ and dhanar10 the issue is the same one you are experiencing - the nanopi M1 is similar to the orange pi boards you have.

    Edited once, last by natumbri ().

  • Hello,

    I 've bought a "MXQ Pro 4k" box from China, which was advertised as a Amlogic 905 TV Android box.

    It turned out that this box is an Allwinner H3 box, not a 905.

    Would it be possible to run LE on it?

    What informations do you need?

    The board is branded as "h3q44_V3.0_20190725".

    Thanks in advance

  • Would it be possible to run LE on it?

    Give it a try, write an image to a card and try to boot from it!

    I'd start with h3 images for beelink x2, libretech h3(those work for me on most h2+/h3 tv boxes pretty well..), and then try out the other ones one after another until you got the one working for you..

  • Thanks! First Impression looks nice. Tried with the libretech h3 image.

    TV works well with TVH 4.2 + Astrometa DVB-C/T usb stick, (Unitymedia Germany cable)

    (Thought this stick works only with TVH 4.3)

    Deinterlacing (Sky Football) doesn´t. But this will hopefully implemented? :)

    Netflix repository coudn´t be installed . But I think I will manage this

  • This is "go to" debugging tool, especially for boot issues.

    I may be doing a silly mistake here. But, how do I get log from serial console? Can you point me to the right instruction, especially for LibreElec & Orange Pi board?

    dejan_  natumbri I tried to connect rx tx gnd pin to my usb serial. On my laptop I use the following command to open serial console:

    $ screen /dev/ttyUSB0 115200

    Then I power my Orange Pi board but I get nothing from serial console.

    Is there something that I missed?

  • dhanar10 - this may sound obvious, but do you have the rx and tx around the right way (ie crossed over)?

    Yes, I wired rx and tx crossed over looking at the label on the pin. Anyways, I switched the rx tx over and it works! I guess it is either the label on my usb serial is wrong or I was just too tired after coming back from work.

    Ok, attached is the log from serial log from Orange Pi One. I compared the log from the one that fails to boot and the one that boots (the image from dejan_).

    jernej It seems like in both cases uboot managed to reach "starting kernel ...". There seems to be not enough info for this from the serial console log I collected. Will removing "quiet" from extlinux.conf make it more verbose?

  • Hi everyone!

    First of all thanx for the great work!

    I am browsing the forum ( and google ) for a few days now, looking for a Kodi 18.x image for my Orange Pi 2.

    The last working one that I could find is "LibreELEC-H3.arm-8.0-devel-20170516112406-r25546-g745f679-opi2.img".

    The "LibreELEC-H3.arm-9.80-nightly-20200304-4608eb2-orangepi-2.img" works great, but due to python 3.0 I can not run all the addons I am used to :(

    I tried "LibreELEC-H3.arm-9.0-devel-20181220211033-147ea78-orangepi_pc.img" , the image boots, but there are no working USB ports, so I cant use it.

    Are there any usable Kodi 18.x images for my OPi2 out there ?

    Thanx for any info! Keep up the great work!

  • Thanx for the quick response!

    I was able to install "LibreELEC-H3.arm-9.2-devel-20200114222052-5d0330e-orangepi_one.img" ( Kodi 18.5 ) on my OPiOne ( with only 512MB of RAM ), configured the basics with keyboard and mouse on the working USB port, than take the SD card from it and inserting it to my OPi2. The device boots, I can control it from my phone using Yatse remote app. It work just as good as my RPi3!

    The problem is NONE of the 4 USB ports on the OPi2 are working under Kodi :(

    Is there a way of adding some USB drivers to OPi2 ?

    Thanx for any info on the subject!

    Edited once, last by pcextreme ().