Date and time in KODI

  • Hello, I have raspberry pi 3 with installed libreelec and KODI (acutal stable versions).
    There is set wrong date and time from installation, is there any chance to set it to current?
    ntp servers are set, but system absolutely ignore it and didn't sync.
    set date and time manually via SSH do not work, system is read-only as I can see.


    Any idea how to set it?
    Thanks.

    • Official Post

    Enable the 'Wait for network' in the LibreELEC settings addon, so the RPi can set the clock settings correctly at boot time. Are you using a wireless network connection?


  • Having the exact same problem. Already tried all the solutions mentioned. Can anyone think of anything else?

  • You could check the time zone in Settings>interface>regional.


    It is supposed to get the time and date from you network, it may get it as GMT, so your time zone is important.

  • Also, In the LibreELEC addon network, you can setup an NTP server.
    I am using


    Timeserver #1 time.nrc.ca


    This in combination with setting up the correct region (as in your screenshot) solve my time problems.