"Segmentation fault (core dumped)" error when running usb sd creator

  • I'm running Ubuntu 16.04


    I downloaded LibreELEC.USB-SD.Creator.Linux-64bit.bin
    Then changed it to executable and ran it as root with sudo.


    Immediately get the error: "Segmentation fault (core dumped)"


    But this ONLY happens when my SD card is inserted into the laptop.


    If I eject the SD then the SD Creator launches with no problem, but then soon as I insert the SD card the program crashes: it just exits.


    I have been using the SD with no issues. It's a Toshiba 16GB. And I just tried partitioning and formatting it to see if that would help, but no luck.


    Thoughts?


    Thanks,
    Ash

  • This will be hard to crack.


    Can you run app with --debug parameter and put result on pastebin.com? Start without sd card and then insert it when program already runs.
    Can you also show me the partitions on this card? sudo fdisk -l /dev/sdX
    And can you wipe sd card with sudo dd if=/dev/zero of=/dev/sdX bs=1M count=10 and then attaching it when program runs.
    And can you try using this sd card with USB reader to see who is doing this problems (sd crd or reader).


    And if you want I can build one special build for you with mode debug messages in. If you are interested...

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)

    Edited once, last by vpeter ().

  • I cannot confirm this bug as yet. Running a fresh Ubuntu 16.04 LTS setup on an Intel i3 3225 Ivy Bridge machine, and with or without a SD card loaded, the Creator tool v1.1.0 starts up normally.


    @randoker
    What sort of machine are you using?

  • Hi vpeter and Klojum thanks for such quick replies. I'm fairly new to linux so please bear that in mind if I say something odd.


    This is an HP laptop, model 15-1215dx (if I can read the label correctly. It's rather worn)


    Not sure if it makes a diff but I'm using a Micro SD card and it is identified in my system as /dev/mmcblk0


    sudo fdisk -l /dev/mmcblk0


    sudo ./LibreELEC.USB-SD.Creator.Linux-64bit.bin --debug


    [hr]


    And can you try using this sd card with USB reader to see who is doing this problems (sd crd or reader).


    Hi vpeter , regarding your suggestion to "try using with USB reader", I am currently putting the micro SD card into an adapter and inserting this into a slot on the laptop that reads SD cards. Here is the exact equipment I am using and it plugs directly into the laptop:


    Edited once, last by randoker ().

  • That worked!


    Haven't tested booting in the Raspberry PI yet but it sucessfully wrote the image.


    Bravo!!! :) :D :rolleyes:


    Thank you!!!

  • Great. Thanks for reporting back.

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)


  • Great. Thanks for reporting back.


    Getting segmentation fault also. Fedora 24 4.7.4-200.fc24.x86_64. The link above is broken. :(


    ./LibreELEC.USB-SD.Creator.Linux-64bit.bin --debug
    App data: Version: 1.1.0, Build date: Sep 17 2016 09:14:11
    Whoami: root
    Whoami: root
    getSizeOfDevice: size 31914983424 device "/dev/mmcblk0"
    Segmentation fault (core dumped)


  • The link above is broken.


    Not anymore - try again.


    This problem happen with internal SD card reader when card is using mmc device (and not sdX). Will be fixed permanently on next update.

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)

  • I just wanted to report that LibreELEC.USB-SD.Creator.Linux-64bit.bin didn't work for me either:

    Code
    1. $ sudo ./LibreELEC.USB-SD.Creator.Linux-64bit.bin
    2. Erreur de segmentation (core dumped)


    I'm on Xubuntu 16.04.1 LTS 64 bit:

    Code
    1. $ uname -a
    2. Linux satellite 4.4.0-38-generic #57-Ubuntu SMP Tue Sep 6 15:42:33 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


    The following version LibreELEC.USB-SD.Creator.Linux-64bit.bin provided by vpeter works great.


    Thanks!

    Edited once, last by raphaelh ().