RK3288 Chiptrip Q8 - How to install LE ?

  • Hello guys,


    Please give a hand to your new friend noob (me). I tried really hard installing LibreELEC on my rk3288 chiptrip Q8 box. This box has more or less the same hardware as the other two rk3288 devices with ready builds and dtb-s so I have some hope it could work. Bear in mind I never installed LE and clearly I lack the necessary knowledge on how to even boot it.


    Here is what I've done so far:

    I chose to try the build for Mqmaker MiQi which I assumed is very similar. Maybe my issues lie in the predefined dtb there.

    I installed the image to a USB drive and to an SD card. Both are plugged in the box.


    I tried rebooting the box while holding the reset with a needle. It successfully goes into recovery screen but none of the options there boots LE. The choice to load "rkimage" from external storage complains it didn't find "update.img".

    I then rooted my device and decided to try forcing an update mode via "reboot update". Turned out after SSHing to my box that the exposed "reboot" executable in path leads to a minibox alternative so "reboot update" did nothing. With some tinkering I found the correct binary at "/system/bin/reboot". That one accepted "update" argument and rebooted. Yet after a blink it still boot android.

    I also tried rebooting to update mode via the LibreELEC app from the play store. It did perform similarly to the "reboot update" command.


    So what do I do wrong? Do I need to alter the dtb file to make the sd card boot? Or do I need another image?

    Edited once, last by sdimkov ().

  • I'm sorry, but I don't know the BOX.

    NanoPC-T4 with LibreELEC, EMBY and TVHeadend Client, 9.2.0
    Odroid-N2 with CoreELEC, EMBY and TVHeadend Client, 9.2.1

    NAS with EMBY Server, TVHeadend Server

  • Btw I got it all working with HW acceleration, ethernet, USB peripherals. If someone is interested I can post details.


    But I didn't do it with LibreELEC, I used Armbian as a base and manually fixed all hw support and installed kodi.

  • Hello, as long as kwiboo released some test images for rockchip devices, I may take a look into.


    Besides, armbian has Community support for the chiptrip q8 (and variants) with all the hardware working, just check the download section for xt-q8l-v10 board. Be careful to read the installation instructions.


    You can use that for a quick jump if you're eager to get LE support for that box

  • Thanks will do exacty that. Appreciate ur help. I have a Gigagytes Brix J1900 arriving soon. Should I download the Generic LibreELEC File and instsll to Internal memory or just run from Bootable Usb?