[S812] MIII Plus 2Gb\16Gb eMMC

  • Welcome back, edit4ever! :)

    Balbes150, if you have problems with mega.nz you could also find android firmwares here: m8s .rar
    5.1 works fine.

    Thanks for your effort!

    • Official Post

    balbes150 here is the version for the Acemax M8S+ that dankec needs. It from the Acemax download center:


    I have similar issues to dankec and hope your build method works!

    Thanks, I downloaded this image. Whenever possible, I'll try to put together a new version based on these data dtb.

    Welcome back, edit4ever! :)

    Balbes150, if you have problems with mega.nz you could also find android firmwares here: m8s .rar
    5.1 works fine.

    Thanks for your effort!

    The archive is 1.7 GB , this is such firmware ???? Or is there a archive of the many other options ?

  • Universal multiboot remained or is now used the former option boot from SD card ?

    I didn't get you... You're asking for the firmware on page #17? I didn't test it yet... Will try today afternoon

  • For testing need universal multiboot TV box. I asked about the availability on Your TV box universal multi-boot. By the way, added to the website version of the image with the dtb data from the firmware, the link to which is given edit4ever. Maybe she could work on M8S Plus.


    Got it!
    This is good question. I've never found an information if M8S+ is multiboot box...

    Is there a solution if it's not?

  • Ok, I tried with the image for M8S+ from U2O1fRPUvCMqJ
    It's the same.... box is stucked in rebooting procedure... Amlogic logo - black screen - amlogic logo - black screen...

  • So these options are not suitable for Your equipment. Something to understand at what stage the problem, we need logs output to the console UART.

    Could you explain me what I have to do? How to get those logs?

  • Ok, I suppose we will stop here, because I don't have this cable...

    balbes, is it possible for you to produce non-multiboot version of firmware (eMMC version)?

  • Try to check with this user. He wrote that when you run external drives not working, but when installed on internal memory (eMMC) in his work. Set-top boxes You have with him are not the same, but he used m8s+ and it worked. Note that there is a risk to brick and will have to restore it via cable.

    LibreELEC for Tronsmart MIII Plus - FreakTab.com

    Balbes, with which user exactly? Your link is leading to your freaktab libreelec thread and nobody mentioned m8s+ there...

  • Hi Balbes,

    Thanks for your excellent work to integrate other forks.

    Yes, it does work on M8S -> S812 + 2Gb ram + 8gb emmc on android 5.1.1

    I followed Post # 11. First time used SD card + toothpick.

    Then used USB as primary boot ->burned same way as SDcard but used USB.

    used-> S6KtL-SVuHcLq -> SD_USB

    Following things works:
    can be boot from USB or from SD card. Both worked.
    ethernet, wifi (ap6330)(both 2.4 & 5), bluetooth - all out of box
    remote - config file have to add in folder. Also, remote config file have to edit -> back button, home button & volume up button to be re-configure.

    Does not work:
    Shut down, sleep -> do not work -> HDMI off. blue light remains on. Some times - all off & then in 1 second, blue light on but HDMI off. To start M8S, unplug power & plug again.

    Other points:
    Boot to nand - works & boots to android. In android - if I keep USB in & press reboot - boots directly to LibreELEC.

    Test video - all worked. Not tested fully ....in progress...will test more formats/codecs & edit afterwards.

    Test audio works - not all checked all format/codecs...will test & edit afterwards.

    Edited once, last by MakaaiD ().