oscam-emu service (addon)

  • Any chance someone can share the latest oscam-emu for libreelec 9.0 ( generic X86 -64 )

    I can only find some builds for ARM based processors ( libreelec for s905/912 boxes etc)

    Thanks...

    I am insane! My mother had me tested.

  • No reply at all means

    1. i should either change OS or

    2. if i insist in using Libre i should buy some of those "all-in-one" Chinesee boxes,

    am i correct? Maybe i m missing something

    I am insane! My mother had me tested.

  • Many thanks L... i appreciate your help ...

    I will definitely try!

    6 more people already downloaded before me (!!!), so it looks like more people need it,

    i m hoping whenever someone has a newer version to post it here and keep this topic alive with updates

    I am insane! My mother had me tested.

  • Edit, April 10: File deleted.


    Here is an update for anyone needing the latest emu version


    First, install service from Livs post above.

    As explained do not update ( you can disconnect the internet when installing, and re connect after you uncheck the "auto update" button in Kodi ( My addons > services ) to prevent future updates


    The, replace the oscam file found in folder .kodi\addons\service.softcam.oscam\bin with the one attached in my post

    Code
    Emu version 791



    In my case, it works fine with Milhouse latest nightly :

    I am insane! My mother had me tested.

    Edited once, last by infoalter: 20 downloads, not a single "thanks" - File deleted ().

  • i use ubuntu. should i just run make? Any special configs for Libreelec? Later after building, just replace the old bin?

  • i did it like this in a ubuntu vm and it worked for me


    install everything needed to compile oscam

    Code
    sudo apt-get update && sudo apt-get install build-essential subversion libssl-dev libpcsclite-dev libusb-1.0-0-dev dialog pcscd

    get the latest build from the official oscam svn

    Code
    svn co http://www.streamboard.tv/svn/oscam/trunk oscam-svn

    configure the build with all the options i need (like smartcardreaders etc.)

    Code
    cd oscam-svn
    make config

    build it with libusb support (not sure if this is needed or a simple make does the same job...think i accidently build it once with PCSC support. libreelec doesnt have the pcsc librarys and it didnt work than...so thats why i used this)

    Code
    make USE_LIBUSB=1

    when the build is complete

    Code
    cd Distribution/

    and there should be your new shining oscam build similar to a filename like this

    Code
    oscam-1.20_svnXXXXX-x86_64-linux-gnu-libusb

    copy it to your librelec box into

    Code
    /storage/.kodi/addons/service.softcam.oscam/bin/

    give it a test run with --help to see if it pops any errors

    disable the oscam addon in kodi for now

    rename the old oscam binary to oscamold (for backup purpose)

    rename the new oscam binary to oscam and make sure its chmod 755

    enable oscam addon in kodi

    profit.

    Edited once, last by rofn ().

  • there are already pullrequest made for LE oscam: update to 11517 by CvH · Pull Request #3461 · LibreELEC/LibreELEC.tv · GitHub

    Compile [LibreELEC.wiki]


    Code
    PROJECT=RPi DEVICE=RPi2 ARCH=arm scripts/create_addon oscam

    you need to edit LibreELEC.tv/package.mk at master · LibreELEC/LibreELEC.tv · GitHub

    latest version is a2ee0528f1de527748aaf7a79982ed112ffa3183 Public Git Hosting - oscam.git/summary (click commit and you see the hash)


    you can delete this line LibreELEC.tv/package.mk at master · LibreELEC/LibreELEC.tv · GitHub or you need to change it to the sha256 hash of the coscam.tar.gz that is downloaded from the url above


    LibreELEC.tv/package.mk at master · LibreELEC/LibreELEC.tv · GitHub

    is just cosmetic but you can change it to currently 11517


    I am not too sure when the update is rolled into the addon repo as our buildserver has some random issue at the moment.