i.MX6 image with kernel 3.14 from solidrun

  • Because blank screen issue can't be fixed by me I decided to build also imx6 images based on Linux kernel 3.14 from solidrun. It has some drawbacks but the most important part (video playing) should work.


    Images can be downloaded from here: Index of /imx6-solidrun-kernel-3.14/


    Current version is LibreELEC-imx6.arm-7.90.007-sr-3.14.img.gz

    Done giving support here because of last events.

    Edited once, last by vpeter ().

  • Thank you for this. :)
    What are the drawbacks that a normal user can notice?
    Only solidrun devs can fix the issues since it's their platform?

  • The drawback depends on your usage. For video playback there is no difference. But mine main idea for using newer kernel is docker support. Which works fine on this platform too.


    This kernel issue we have can only be fixed by main kernel author. Who is btw doing great job to bring imx6 support in Kodi!

    Done giving support here because of last events.

  • This kernel seems to have the issue with cec not working after tv has been shutdown/screen off and started again.
    Other than that it works better on the playback.
    Edit:
    Went back to the newer kernel version, rather have the playback issues than cec not fully working.

    Edited once, last by leripe ().

  • leripe, check settings for cec like action when tv powers off. I think default value is suspend which is not supported on cuboxi. Maybe some setings changes could help with this.

    Done giving support here because of last events.

    Edited once, last by vpeter ().


  • leripe, check settings for cec like action when tv powers off. I think default value is suspend which is not supported on cuboxi. Maybe some setings changes could help with this.


    Tried that, did not help.
    Also tried to put the other standby/power on settings to ignore/off from the cec.

  • Thanks for feedback. I will test this in next days and maybe, just maybe we would have luck to get a fix
    [hr]


    Went back to the newer kernel version, rather have the playback issues than cec not fully working.


    What playback issues? I though it works perfectly?

    Done giving support here because of last events.


  • Thanks for feedback. I will test this in next days and maybe, just maybe we would have luck to get a fix
    [hr]


    What playback issues? I though it works perfectly?


    Ok, thanks. :)


    Older kernel = no playback issues, but it has the cec issue
    Newer kernel = no cec issue, but it has the playback issue


    CEC issue: CEC does not work after you close tv/screen and turn it back on.
    Playback issue: Sometimes during the playback the screen goes black with no audio during playback and this does not pause the playback.


    Haven't noticed any other issues. (or maybe some crashes/freezing here and there but nothing that I could reproduce)

  • About cec not working on 3.14 - this are my cec seetings



    I can manually turn off TV or leave screensaver kick in. After powering Tv back on CEC is still working.

    Done giving support here because of last events.

  • Tried those and it worked if I quickly turned the TV back on.


    I previously had these settings also off:
    Devices to power on during startup
    Devices to power off during shutdown
    Send "Inactive source" command on shutdown
    Put devices in standby mode when activating the screensaver
    Wake devices when deactivating the screensaver


    With the newer kernel the CEC works with your settings and mine.


    I have been switching between the kernels with the .tar files, is that okay or can it cause problems?


  • Yes, it is okay.


    Can you try this image: LibreELEC-imx6.arm-7.90.005-sr-3.14.img.gz
    For me with Samsung TV UE40JU7090 still working as it should. Maybe it is your TV to blame


    Hmm.. I think it might have something to do with my soundbar connected via hdmi-arc since cec works after turning the screen back on if the soundbar has been shutdown before. Powering on the tv turns on the soundbar automatically (doesn't matter if hdmi input for cubox is selected or just normal tv).
    I'll do more testing tomorrow.
    No issue like this on the xbian 4.4 kernel, though.


    Edit: Did not have time today, let's see tomorrow. Sorry.

    Edited once, last by leripe ().

  • Thank you for this version vpeter.


    With the regular version I had sound issues.
    With HDMI (directly to TV) I had audio stutter every couple of seconds just like this LibreELEC
    With SPDIF the sound was completely distorted. It was like the audio was sometimes being slowed down dramaticaly resulting in music in movies being completely off-key and voices sounding like they are under water.


    With this kernel everything is fine.
    Any idea to what this is related? Can we fix this with audio settings so I can use the regular version?


  • With this kernel everything is fine.
    Any idea to what this is related? Can we fix this


    Use what works for you. As you can see imx6 project doesn't have any real dev to fix most issues.

    Done giving support here because of last events.

  • The only problem is who will analyze them and fix the issues

    Done giving support here because of last events.


  • The only problem is who will analyze them and fix the issues



    Okays, log providing was too hard since apparantly logs have all the info on my system, ip addresses, files, shares etc.
    It was too pain in the ass to try to CTRL+F censor them..
    Sorry..
    I'll rather live with the bugs than try do that again.




    But for just testing the 3.14 kernel, Index of /imx6-solidrun-kernel-3.14/, CEC TV remote issue I noticed this:


    When turning the TV ON and OFF:


    CEC works if I do not have my soundbar connected (via hdmi-arc).
    CEC does not work if soundbar is connected.
    CEC works if I turn OFF soundbar when I turn OFF the tv, so turning ON the TV will turn ON the soundbar automatically and this somehow "wakes" up the CEC to work with TV Remote.


    With the "test1" 3.14 kernel, test1, has the same result as above "not test1" kernel.


    With the xbian 4.4 kernel, Index of /imx6-xbian-kernel-4.4/, there's no issue with CEC TV remote with or without the soundbar connected.

  • Can you describe in detail how you have all 3 devices hooked up? Cuboxi to TV on one hdmi and also soundbar to tv on another hdmi (with arc)?


    I will play a little over weekend and see if I can reproduce the issue. But I don't have any soundbar - only Onkyo AV receiver. And in my tests it was turned off and cuboxi was connected directly to tv.

    Done giving support here because of last events.

    Edited once, last by vpeter ().


  • Can you describe in detail how you have all 3 devices hooked up? Cuboxi to TV on one hdmi and also soundbar to tv on another hdmi (with arc)?


    I will play a little over weekend and see if I can reproduce the issue. But I don't have any soundbar - only Onkyo AV receiver. And in my tests it was turned off and cuboxi was connected directly to tv.


    Cuboxi directly connected with hdmi to TV's hdmi port..
    Soundbar directly connected to TV's another hdmi port which is a hdmi-arc port.
    With this I can use my TV's remote to control volume on the soundbar and navigate kodi on cuboxi.
    The soundbar has a built-in feature which turns it ON when turning the TV ON.
    TV also remembers the last hdmi input which was selected, so I Kodi was selected when I turn the TV OFF, it is selected when I turn it ON.
    The soundbar turns ON automatically no matter which hdmi/normal tv was selected before turning the TV OFF.
    The soundbar also detects when the keep audio alive timer ends on Kodi, when the timer is out the soundbar triggers 15min(?) automatic shutdown and doesn't turn ON automatically when I play something on Kodi if it has shutdown. So the soundbar only turns ON automatically when both TV and soundbar are OFF, and the TV is turned ON.


    When I turn off the soundbar the TV switches to TV's speakers, but this doesn't wake up the CEC for TV's Remote.
    I literally have to unplug soundbar's hdmi from the TV's hdmi-arc port and then turn the TV OFF and ON for CEC to work with the TV's Remote with the 3.14 kernels.


    I'll try to clarify more if needed. :)