Libreelec freezing up when scanning library

  • Hi everyone.

    I have a problem that seems to be intermittent and was wondering if anyone else has had this or can point me in the right direction to logs to find out the cause.


    Some times when I add a new video file to libreelec and I update the library to scan, my raspberry pi 3 and libreelec will freeze up and the only thing I can do is to pull the power out.


    It doesn't happen everytime but I would say it has around 50% of the time since using LE9


    This never happened on 8.2.5

    It does it on my new 64gb SD card I brought specifically when the new LE9 came out for a fresh install and I've also upgraded my old 32gb SD from 8.2.5 to 9.0.1 and have been using that the past couple of days to see if it has the same problem on that to rule out if it is the SD card.

    And unfortunately it has also just done it on that SD card as well which is what brings me here for help.


    Thanks in advance

    Rob

  • More info on this.

    I first noticed this when setting up my new install on the 64gb SD card.

    I wrote the LE9 image to SD card.

    Once loaded up I changed a couple of settings like I normally do (basic stuff like my location etc).

    Then I connect my external drive with my media on reboot and check all is mounted correctly.

    The drive is formatted in ext4.

    When I first added my movies folder to Kodi and scanned everything went fine the was only 86 movies.

    But then when I scroll through my list of movies that's when it will completely freeze up the pi.

    It did this a couple of times when I first added to library.

    It seemed once it had fetched artwork when scrolling through all my movies that the freezes didn't appear again or so I thought until adding more.

    I now have 91 movies some added to library no problem some caused the freeze.

    For example, tonight I copied over a movie from my computer and update my library (this part always goes ok) then when I navigate through my library to that movie that's when it will freeze my pi up and I have to pull the plug (even left it 10mins to see if it would respond) so it almost seems like when highlighting a newly added video and it tries to fetch artwork that's when it freezes.


    Thanks in advance

    Rob

  • This is really weird!

    I think I'm not the best person to help you, but I will try.


    If you reboot LibreELEC and do this things after it will freeze too?


    You use a lot of add-ons?


    Try check the memory usage with top command (you also can press the m key 3 times to see the memory usage bar) before and during the library scan to see what process are using more memory.


    In my experience LibreELEC freeze when it have no memory available. So, I think some process of your configuration are using a lot of memory.

    Supercalifragilisticexpialidocious! (inscribed in large friendly letters)

    My hardware is a Raspberry Pi 3b

  • The only add-ons I use are gamestarter, and I use retroarch and emulationstation from the gamestarter repo.

    And then whatever add-ons install when using my choice of skin.

    That's it no other add-ons than what's listed above.


    Surely it wouldn't be memory,

    For example switch on my pi, add 1 movie to my hard drive connected to my pi,

    Then update library, all ok so far.

    Then I'll navigate to that film, highlight it and this is when it will fetch artwork, bang! That's when the system freezes up.


    Now it doesn't do it every time that's what's making it hard to know what it is, that's why I asked here.

    I can add 20 films for example it will work fine, I can add 3 films it will freeze. There is no pattern to the freeze at all.


    But it has happened at least 10 times since I posted on here but nobody replied so I've just learned to live with it.

    My only concern is keep pulling the plug will probably end up killing my SD card.


    Thanks

  • What skin are you using?


    Try to check memory RAM usage anyway. At least it will tell you that are not memory problem. And tell how much memory is used before and after a scan that freeze.


    Send logs to.

    Supercalifragilisticexpialidocious! (inscribed in large friendly letters)

    My hardware is a Raspberry Pi 3b

  • I am using pellucid skin, but when I first started having this problem (which is since LE9) and started from fresh and after adding my media to library using the default skin it froze up 3 times scrolling through my movies, when it appears to fetch extra artwork.


    I'll try what you suggested next time a add a video file, although like I say it may or may not happen as there is no pattern to it.


    Thanks

  • Right! Aways check the memory usage when you do a scan!

    Usually alternative skins use more memory, because have more functions.

    I use a Raspberry too. I tried use anothers skins but aways return to stock, because it use less memory, and I prefer priorize memory for anothers add-ons I use.

    Supercalifragilisticexpialidocious! (inscribed in large friendly letters)

    My hardware is a Raspberry Pi 3b

  • Ok update.

    So last night I added 1 film.

    Before I added the film memory was 80% free (608mb)

    After I updated library it was 79% (598mb)


    I then went to movies and navigated to the film I just added and boom, it froze up.

    It loaded poster but didn't load background artwork before it froze up.


    And just to clarify this was with default Kodi skin, I'm leaving it on this for the time being until I've found this problem.


    I bloody forgot to enable debugging log before this unfortunately, so I've enabled it now and next time I experience this freeze up I'll post log.


    Thanks

  • Weird, in my raspberry memory usage is opposite and don't freezes. But is supposed to you check memory too when navigate library, since freezes in that point too. And you can delete some movie of the library and scan it again to reproduce this situation (you don't need to download another).

    Supercalifragilisticexpialidocious! (inscribed in large friendly letters)

    My hardware is a Raspberry Pi 3b

    Edited 2 times, last by edjalmo ().

  • I have exactly the same problem. It seems that it is a LibreELEC version problem since I do not have it in 2 other Android TV boxes with Kodi Leia.

  • Problem is still there for me aswell

    And I can reproduce it every time now I just don't know what it is, Ive monitored memory during it happening with SSH from my phone using the top command but this isn't memory related, when it freezes it doesn't appear to to run out of memory before kicking me out off SSH due to host going down (because of the crash).


    How I can reproduce the problem is by this (even a clean install will do this)


    I add my movies location to the library.

    I then navigate to movies and my list of approx 100 movies is there.

    I keep pressing down on the keyboard going through the list of movies as it fetches posters and background images.


    It will then at some point not load poster or fanart for a movie (this is random as to which movie it does this from.


    Then I press down again and next movie doesn't load any poster etc, if I press down 2 more times it will then freeze the whole pi3.


    So basically if I go scroll down through 4 more movies after the first time it doesn't load poster and fanart that's how I can recreate the crash of the pi


    Now the strange part it that it is completely random as to when it decides to do it.


    I can do a fresh install add my library and it happen 2-3 times whilst scrolling through my newly added library.


    I can do a fresh install and it not do it once whilst adding my library.


    And then there are times when I can add one extra video to my library, update library as normal, scroll down to the new film I just added, no poster or fanart appears, this is when I know if I scroll down 4 more films it will freeze (this doesn't happen all the time again it's random).


    I've just learned to live with it I'm affraid.


    I have to pull the plug every time it does it but I don't know what else to do.


    One other thing to mention.

    I use a add-on call internet archive game launcher, and this will freeze the pi in the same way.

    I choose a game console from the list, scroll through the list of games it will then randomly at some point not load a poster or fanart for a game, if I then scroll down 4 more games the pi will freeze up.


    So the exact same problem fetching artwork in a add-on so surely it has to be something to do with fetching artwork that is the problem.


    Like I say random when it happens but when it does always freezes up the pi when scrolling down 4 more times.


    And just to add that problem has only started happening in version 9 of LibreELEC and does it on all of my pi's which is 2 pi3 and 1 pi2


    Rob

  • Without a debug log nobody's going to be able to help.

    With one there's at least the possibility.

    If it's reproducible then:

    enable debug logging

    restart kodi

    reproduce the problem

    if you pull the plug then after restarting upload the contents of kodi.old.log to a paste site and link here.