remote context broken after upgrade to Kodi 18

  • Just did a fresh install of Kodi 18 and then used Backup to restore my settings.

    However, the Xbox One Media controller (not joystick) tries to open a PVR device.

    I am running an Intel Nuc and all worked fine before the upgrade.

    Does any one have a suggestion how to fix as this seems to be the only button not working.


  • Can you try running the following 2 commands and report back if that works?

    1. ir-keytable -k 0x80d86f=KEY_MENU
    2. systemctl restart kodi

    so long,


  • Just thought i would post back. I reverted to ver 8.2.5 and copied the Lircmap.xml & Keymaps.xml files

    I then upgraded to ver 9.0.0 and then placed in the correct folders.

    Rebooted and my context menu now works correctly.

    I checked the new versions of Lircmap.xml & Keymaps.xml and there are a lot of differences.

    in my old Lircmap is <remote device="devinput">

    and in new is also <remote device="devinput-32"> & <remote device="devinput-64">

    comparing these , there are some differences which could be why kodi tries to initiate a PVR when i click the button

    on Xbox One Media Remote ( top right button)

    I am running the 64bit version. so what would i need to change in this file to keep the new Lircmap and have same

    keymaps as ver 8.2.5

    If not then it seems to work ok.


  • "devinput" is the relevant section in Lircmap.xml - you can ignore the devinput-32 and -64 ones.

    In Kodi 18 the mapping of the EPG key was changed from "title" to "guide" KEY_EPG is wrongly mapped to title instead of guide · xbmc/[email protected] · GitHub

    If you want to change that it's best to use the Lircmap.xml from Kodi Leia and just modify that single mapping in the devinput section.

    As an alternative you can also keep the Lircmap.xml as it is and create a remote.xml keymap and map "guide" to "ContextMenu".

    so long,


  • I had the same exact problem with 2 remote keys on my Harmony 650 remote. Both the "Guide" and the "Menu" buttons changed functions when upgrading to LE 9.0 (Kodi 18). The "Guide" button used to activate the context menu and the "Menu" button used to activate the Kodi "home" function. I had to reprogram the remote using the Logitech Harmony software to change the "Guide" key back to "DVD Menu", which is the context menu on Kodi. But now both the Guide and Menu keys do the same thing (Kodi context menu). I lost the "home" function and don't see that function mentioned in the Logitech Harmony software.

    I'm also running an old 3rd gen Intel NUC

    With Kodi 17.6 the Menu button was the "Home" button for Kodi. The Guide button was Kodi's "Context Menu"

    With Kodi 18.0 the Menu button is Kodi's "Context Menu". The Guide button is "PVR Device".

    I used Logitech Harmony software to program the remote's Guide button back to Kodi's context menu (Logitech calls it DVDMenu)

    Edited 2 times, last by blueribb ().

  • I'm not familiar with the Harmony remotes but MCE remotes usually have a button with the Windows logo on it. This button generates a KEY_MEDIA inpuit event which brings you back to the home screen.

    Just tested that here with an HP branded MCE remote

    1. 22:25:31.560 T:1860170608 DEBUG: LIRC: - NEW e2 0 KEY_MEDIA devinput (KEY_MEDIA)
    2. 22:25:31.590 T:1937625760 DEBUG: HandleKey: percent (0x25) pressed, action is PreviousMenu

    BTW: completely forgot, you can also partially override the Lircmap.xml file (like the other keymap xml files), no need to copy the whole file from /usr/share/kodi/system (which may cause issues on updates) and edit it.

    so long,


  • so what part do i need to edit in Lircmap file. I am using the Xbox One Media Remote to get the context menu working with ver 9.0.0 Lircmap file

    the button is the top right one.


  • Try this .kodi/userdata/Lircmap.xml file (untested)

    1. <lircmap>
    2. <remote device="devinput">
    3. <menu>KEY_EPG</menu>
    4. </remote>
    5. </lircmap>

    Or use the keymap editor addon.

    so long,


  • many thanks. works fine. i did try the map editor last time , but as soon as i pressed the key to map it pops up msg about not having a PVR.

    anyway. all works fine.

  • Translator:

    I have a similar problem. The commands and Lircmap file did not help. Keymap (and Kodi) sees a pair of buttons as one (img). I use Rii mini i8 and GenBOX MX3 PRO. In the previous version (Kodi 17) everything worked fine.

    RPi3, Kodi 18.2, LibreELEC 9.0.2

    Edited 2 times, last by drrak ().

  • I’m also having this same problem with both my “Menu” and “Guide” buttons on my Harmony 655 after upgrading to Kodi 18. I used the Keymap Editor app to reprogram my “Guide” button to Kodi’s “Context Menu”, but can’t find where the Kodi “Home” button is. Any ideas?