Posts by wongnog

    Hi guys,


    I have an Asus Chromebox running LE v7.90.010 ALPHA, and I'm noticing HDMI handshake issues when enabling the setting for "Adjust display refresh rate to match video". I have the Kodi interface set for 60 fps, and my TV refresh rate can adjust to play 24 fps content without issues. However, when I press Stop and the interface tries to reset back to 60 fps, that's when I notice HDMI handshake issues. My screen goes black, then blue, then some snow, then the Kodi interface flashes briefly. The only fix for this is to set my unit to standby and then wake up from standby, or I unplug the HDMI cable and plug it back in.


    If I set the Kodi interface to 30 fps, then I can play 24 fps content without issue, and also return to the Kodi interface without issue. However if I try to play a 29.97 fps video file, I get just a black screen until I press stop!


    My final resolution is to disable "Adjust display refresh rate to match video", and leave the Kodi interface at 60 fps. It's just that I did not have this issue with earlier LE v7.90 ALPHA builds, and I never had problems with this setting on OE running Kodi 16. My TV is a 2014 Samsung 1080p HDTV, and I have an Onkyo receiver.


    I noticed another user with the exact same problem posted in the Kodi forum, but they referred him/her to the LE forum.
    Glitches with "Adjust display refresh rate to match video"


    Is this a known issue? What additional info do you guys need to help troublesheet this? Thanks!

    I installed the chromium build available from the openelec repo and this one still had slow scrolling and lagging, where it used to run fine on my OE build. So I'm guessing it's an LE issue or krypton alpha bug? All my movies and videos play fine btw

    Ah yes maybe that's it. Can I downgrade to an earlier version? Or I can wait for you to add it back to the next build.

    The chromium hardware accelleration settings are very much a hack. It may work it may not, there isn't much I can do about it.


    check the special page 'chrome://gpu' and see what the render methods say.


    also make sure that chromium isn't running in the background because when you change the settings for chromium from kodi they won't change.
    in chromium settings ('chrome://settings') scroll to the bottom and disable running in the background.


    OK I did as you suggested and disabled running in the background. I also disabled hardware acceleration in both chrome://settings and the add-in settings. Page scrolling is still very choppy compared to chromium on my previous Openelec build. Here's the output of my chrome://gpu screen:Graphics Feature Status

    • Canvas: Software only, hardware acceleration unavailable
    • Flash: Software only, hardware acceleration unavailable
    • Flash Stage3D: Software only, hardware acceleration unavailable
    • Flash Stage3D Baseline profile: Software only, hardware acceleration unavailable
    • Compositing: Software only, hardware acceleration unavailable
    • Multiple Raster Threads: Disabled
    • Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    • Rasterization: Software only, hardware acceleration unavailable
    • Video Decode: Software only, hardware acceleration unavailable
    • Video Encode: Software only, hardware acceleration unavailable
    • WebGL: Unavailable


    Driver Bug Workarounds

    • clear_uniforms_before_first_program_use
    • count_all_in_varyings_packing
    • disable_post_sub_buffers_for_onscreen_surfaces
    • scalarize_vec_and_mat_constructor_args


    Problems Detected

    • GPU process was unable to boot: GPU access is disabled in chrome://settings.
      Disabled Features: all
    • Clear uniforms before first program use on all platforms: 124764, 349137
      Applied Workarounds: clear_uniforms_before_first_program_use
    • Mesa drivers in Linux handle varyings without static use incorrectly: 333885
      Applied Workarounds: count_all_in_varyings_packing
    • Disable partial swaps on linux drivers: 339493
      Applied Workarounds: disable_post_sub_buffers_for_onscreen_surfaces
    • Always rewrite vec/mat constructors to be consistent: 398694
      Applied Workarounds: scalarize_vec_and_mat_constructor_args
    • Raster is using a single thread.
      Disabled Features: multiple_raster_threads
    • Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
      Disabled Features: native_gpu_memory_buffers


    Version InformationData exported7/11/2016, 8:59:59 PMChrome versionChrome/50.0.2661.75Operating systemLinux 4.6.2Software rendering list version0Driver bug list version8.59ANGLE commit idunknown hash2D graphics backendSkiaCommand Line Args--user-data-dir=/storage/.kodi/userdata/addon_data/browser.chromium/profile --test-type --start-maximized --enable-gpu-rasterization --enable-accelerated-2d-canvas --ignore-gpu-blacklist --ppapi-flash-path=/storage/.kodi/addons/browser.chromium/bin/PepperFlash/libpepflashplayer.so --alsa-output-device=hdmi:CARD=HDMI,DEV=0 --window-depth=24 --flag-switches-begin --flag-switches-endDriver InformationInitialization time0In-process GPUtrueSandboxedfalseGPU0VENDOR = 0x0000, DEVICE= 0x0000OptimusfalseAMD switchablefalseDriver vendorMesaDriver version11.2.2Driver date Pixel shader version Vertex shader version Max. MSAA samples Machine model name Machine model version GL_VENDORIntel Open Source Technology CenterGL_RENDERERMesa DRI Intel(R) Haswell MobileGL_VERSION3.0 Mesa 11.2.2GL_EXTENSIONS Disabled Extensions Window system binding vendor Window system binding version Window system binding extensions Window managerFluxboxCompositing managerNoDirect renderingYesReset notification strategy0x0000GPU process crash count0Compositor InformationTile Update ModeOne-copyPartial RasterDisabledGpuMemoryBuffers StatusATCSoftware onlyATCIASoftware onlyDXT1Software onlyDXT5Software onlyETC1Software onlyR_8Software onlyRGBA_4444Software onlyRGBX_8888Software onlyRGBA_8888Software onlyBGRX_8888Software onlyBGRA_8888Software onlyYUV_420Software onlyYUV_420_BIPLANARSoftware onlyUYVY_422Software only

    Just installed Chromium 8.0.102 on a LE 7.90 alpha build for Chromebox. Flash is running great, but I noticed page scrolling a full screen video is very choppy. I have tried turning hardware acceleration on and off (choosing Intel for on as the Chromebox is a celeron CPU), but no difference between the two. Is this a LE 7.90 alpha bug? Or a Kodi setting I need to fix? Thanks!