Nexcloud Docker addon - Data folder permissions

  • Hello!


    Today I installed the docker "Nextcloud" add-on which worked great up to the moment i wanted to use my mouted hard disk as the data folder.

    The following error is shown on the web interface: "Your data directory is not writable".


    Apparently the problem is, that my mounted hard disk/folder needs to be writable for the user "www-data" in order to work for nextcloud.

    Is this possible with LibreElec?

    Using the following method to mount the drive is not working:

    Mounting network shares [LibreELEC.wiki]

  • The thing I want to do is mount /storage/videos/ as external drive with local option choosen from tab. It wont let me :(



    Here it is folder /storage/pictures owned as nobody:users and cant mount it as local drive

    The docker container doesn't know where /storage/pictures is. It only knows the folders that are mapped. If you go into the addon settings, you'll see that there is a mapping for /data and you pick a folder for it on libreelec. That libreelec folder gets mapped to /data inside the container so nextcloud only sees /data.


    So pick a location where you want your data to be stored, and select that location in addon settings, /data mapping. Then in nextcloud, you'll find that location as /data

  • Thank you for you reply aptalca! Appreciate your willing to explain or help. I do known where configs and /data is mapped on my hdd as I've changed those settings along with port used.

    As you see in my previous post I would like to map or mount folder which is outside of nextcloud container. System is ready and running two years now so no point to move files I would like to share to a nextcloud data folders. Let me mount /storage/pictures/ and some other folders and I'll be happy.

    Symlinks does't work with nextcloud and will never be so please help me to get access to my existing files in storage through nextcloud web viewer or ios app please. Hope you know what I mean 😉

  • One option is to add local share in /storage/.kodi/addons/docker.linuxserver.nextcloud/bin/docker.linuxserver.nextcloud

    Code
    1. -v /storage/downloads/test3:/test3 \

    and this folder has nobody:users permissions.

    And I added /test3 under External storages.

    Gone...

  • I've been meaning to add an "extra parameters" setting where users can add any additional docker parameter like extra ports or mapped folders etc. when needed.


    I'll do that today or tomorrow and then you can add the additional folder mount.


    Vpeter's solution works, but would be removed if the addon is updated or reinstalled

  • I've been meaning to add an "extra parameters" setting where users can add any additional docker parameter like extra ports or mapped folders etc. when needed.

    Vpeter's solution works, but would be removed if the addon is updated or reinstalled

    Yes, that's why it would be useful to have it in settings.


    chewitt: You can see that docker needs same or even higher support to get it running than native apps like with Entware :D

    Gone...

  • vpeter your trick with editing /storage/.kodi/addons/docker.linuxserver.nextcloud/bin/docker.linuxserver.nextcloud works like a harm!

    Too bad sharing links to external storages doesn't work and local is treat as external.

    Is there any other option to mount /storage/pictures/ and be able to share links from it ?

  • Too bad sharing links to external storages doesn't work and local is treat as external.

    Can you explain little more what dowsn't work? I'm not familiar with nextcloud and needs to repeat the issue myself :P

    Gone...

  • well best feature in nextcloud is to share files/folders with public links without password if you want to.


    When you're in nextcloud webview on right hand side there are ...

    press it beside any file in nextcloud foler and then try same with external volume you mounted as external in your case test3 😉


    Thank you for your patience 😊

  • well best feature in nextcloud is to share files/folders with public links without password if you want to.

    Ok, same as with Dropbox. Didn't think on that :(


    And it is easy fix when using External storage: in the mount settings you must enable sharing on the remote storage.




    Gone...