S905/MXQ Pro - disable internal wifi

  • Hi,


    I found internal wifi to be unstable and low transfers. I use usb wifi dongle instead and it works without any problems. However, now I 'm getting 2 interfaces: wlan0 and wlan1 and I'm always confused which one is internal wifi (they even keep swapping sometimes).


    Any way to completly disable/blacklist internal wifi kernel module?

  • try setting a fixed ip address for the one you want.

    Samsung RU7400 Onkyo HTX22HDX Mecool M8S Pro L (Coreelec) Nvidia Shield (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Beelink MiniMKIII (CoreELEC)

    Synology DS414 Plex Pass

    :)

  • I want completly disable internal wifi. As it's linux, this could be done eaisly by blacklisting kernel module, but I'm not sure how to indetify which module is it and how to blacklist, because corresponding configuration should be in /etc/modprobe.d.

  • I know, but since I'm not sure what hardware is there, their names tell me nothing. And commands like lspci ethtool are not available

  • Well.. even if you don't know what's there, the module list would mean something to other people.

  • Well.. even if you don't know what's there, the module list would mean something to other people.

    Ethtool is there. For built in wifi card:


    So, to disable:

    Code
    1. rmmod ssv6051


    I guess there is blacklist in /storage/config

  • Code
    1. echo "blacklist ssv6051" > /storage/.config/modprobe.d/blacklist.conf
    2. reboot

    ^ should do it - and that driver is a complete POS, it should be removed (and it will be in the mainline kernel switch).

  • Code
    1. echo "blacklist ssv6051" > /storage/.config/modprobe.d/blacklist.conf
    2. reboot

    ^ should do it - and that driver is a complete POS, it should be removed (and it will be in the mainline kernel switch).


    Afaik internal wifi is the same unstable on original Android firmware on this box. So I am not suspected. From other side, better than nothing.