External drives with Linux-filesystem get unwanted rights if once connected to Libreelec

  • I use USB-disk and harddisks with ext4-fs for videos. these drive have the rights 777 and are writeable for everyone at home. If I connect those drives via USB to my Wetek_play2 with Libreelec, the rights are changed to "only root can write onto that drives" and I have to set the rights back. How ca I change this behaviour to "do not change anything".


    Spielmops

  • Kodi in LibreELEC's Linux OS only has one user: root. So that kinda explains it all.

  • I'm not sure why we'd change permissions on the drive. It would be interesting to understand what udev is doing when the drive is connected. Perhaps monitor with udevadm to find out. NB: It's not a good answer, but iIt's probably easier to have a udev rule on the other computers that detects mounted drives that don't have 0777 perms and run a command to reset the perms than it is to correct the LE end.

  • I would like to someone telling me the exact content of that file. If I know, I can overwrite it at .config/udev.rules.d


    And I think it would be a good idea to change that mount-rule. If I lent my car to any president, that does not mean, that my car is now his car ....


    Spielmops

  • udevil seems to have it's config file hardcoded to /etc/udevil/udevil.conf, which is located in readonly system and from a quick glance there doesn't seem to be an option to override/change that.


    But I've already opened a PR to drop mount_point_mode udevil: don't change permissions of mounted filesystems by HiassofT · Pull Request #3165 · LibreELEC/LibreELEC.tv · GitHub


    Mounting some filesystem should never result in any modifications of it and doing a chmod() is a really devilish action of udevil.


    so long,


    Hias

  • I installed Libreelec 9.0 today and found, that this behaviour is still existing. Very sad ...


    Spielmops

  • The fix is included in LibreELEC since mid December and I just tested with the final 9.0.0 release on RPi3B+ and it worked fine:


    USB HDD with ext4 FS with root dir set to mode 2775, plugged into LE, mode still showed up at 2775, unmounted in LE, plugged into notebook, mounted and mode still was 2775.


    Please retest and if you got different results tell us what exactly you did.


    so long,


    Hias

  • Thanks for the answer. It's Ok now, I tricked myself with a test-disk. Now I tested more careful and all is fine.


    Spielmops