Trying to disable IR Receiver

  • Hi all,


    I have a TX92 running LibreELEC (wrxtasy-kszaq): 8.2.4.1.force.444.10bit and I want to disable the IR Receiver in the TX92 as I have installed a Flirc IR Receiver so I can place it into a better position. I'm also using a Harmony configured for Kodi and the Flirc.


    The problem is I'm getting double responses for most commands when using the Harmony.


    ir-keytable returns below when the Flirc is plugged in or not:


    Code
    1. ir-keytable
    2. Found /sys/class/rc/rc0/ (/dev/input/event4) with:
    3. Driver dib0700, table rc-dib0700-rc5
    4. Supported protocols: rc-5 nec rc-6
    5. Enabled protocols: rc-5
    6. Name: IR-receiver inside an USB DVB re
    7. bus: 3, vendor/product: 1415:0003, version: 0x0100
    8. Repeat delay = 500 ms, repeat period = 125 ms


    How can I disable the built in IR Receiver in the TX92 and keep the Flirc going?


    TIA


    Greg

  • You can disable the IR receiver in your DVB dongle by creating a file /storage/.config/modprobe.d/dvb-usb-disable-ir.conf with the following content:

    Code
    1. options dvb-usb disable_rc_polling=1


    Or just put a piece of black (gaffer) tape over the IR receiver.


    so long,


    Hias

  • Hi guys, I have a similar request. Firstly, I followed the instructions above and it did not have the proper effect for me.


    I have a KIII Pro and a Vorke Z6. The Vorke is my test box that I turn on now and again to test new builds of LE or CE. The KIII Pro is my terrestrial and satellite TV box and I never want it to turn off but when I turn on my Vorke it turns the KIII Pro off. Even more annoying is that when I turn the Vorke off again it does not turn the KIII Pro back on. I have a Flirc in the KIII Pro but it will only power off (via menu) and will not power on so I have to use the KIII remote or press the button on the top.


    Before I added dvb-usb-disable-ir.conf

    - the power button on the Vorke would power off both the Vorke and the KIII Pro but would only power on the Vorke

    - the power button on the KIII Pro would power on both but only power off the KIII Pro

    - Pressing the power button on the Flirc remote only brings up the shutdown option screen and doesnt actually shut anything down unless I pick something


    After adding dvb-usb-disable-ir.conf

    - same as before, he power button on the Vorke would power off both the Vorke and the KIII Pro but would only power on the Vorke

    - the power button on the KIII Pro will now only power ON the Vorke and the KIII Pro but will now not power off either


    So the only change after adding the file is that the KIII Pro remote will no longer power off the KIII Pro ( but the Vorke remote will, grrr! )


    I am not sure where the IR receiver is on the KIII Pro, if the power button on the KIII Pro is also the IR receiver I cant put tape on it. I tried just blocking the top and front but the signal still got through.


    Any help disabling the IR receiver entirely would be appreciated. Even just disabling the power off function, powering on from a powered off state is probably harder but not an issue and it should always be on.

  • blueribb Thanks, that helped somewhat. I put tape over that area in the front and I can tell the signal is degraded because it only turns on/off every 5 presses of the button now. Still getting through though. I'll try more tape.