Wrong refresh rate - LibreELEC (Leia) v8.90.007

  • Kennz

    Changed the title of the thread from “Wrong resfresh rate - LibreELEC (Leia) v8.90.007” to “Wrong refresh rate - LibreELEC (Leia) v8.90.007”.
  • Have you whitelisted the resolutions that Kodi should use when doing "adjust refresh" ? If you haven't, everything will run at the deafult 1080p60 resolution, which isn't ideal on all hardware.

  • Hello chewitt. Thank you for answer.


    According to intel nuc 2820 specification:


    Quote

    The maximum supported resolution is 1920 x 1200 @ 60 Hz,

    24 bpp (WUXGA). The HDMI port is compliant with the HDMI 1.4 specification.


    Libreelec 8.2.5 with factory settings don't have issues with the same video file.

  • The maximum supported resolution is 1920 x 1200 @ 60 Hz,

    24 bpp (WUXGA). The HDMI port is compliant with the HDMI 1.4 specification.


    Libreelec 8.2.5 with factory settings don't have issues with the same video file.

    That's .. not exactly an answer to Chewitt's question. Also, is your "Sync display to refresh rate" option still enabled? It may have been reset during the upgrade. In order to access and enter whitelisted resolutions/framerates, the GUI settings level "Expert" must be enabled. :)

  • I think I have the same (or similar) problem with Intel NUC

    - 8.2.5 plays smooth

    - 8.90.007 has freeze-and-jump issues on heavy movement like panning every second or so. Looks like the buffering issue for me. Appears on both heavy and lightweight content with no apparent difference. Adding advancedsettings.xml does not fix the issue.

    XML
    1. <?xml version="1.0" encoding="UTF-8"?>
    2. <advancedsettings>
    3.     <cache>
    4.         <buffermode>1</buffermode>
    5.         <memorysize>139460608</memorysize>
    6.         <readfactor>20</readfactor>
    7.     </cache>
    8. </advancedsettings>

    Thanks!

  • I changed whitelisted to max suported and I changed "adjust display resresh rate" to always. Still having problems with videos

    I think you misunderstood the whitelist functionality. It's not about setting a maximum, you need to select/enable every resolution/framerate combination that you think you will need for all the videos you may play.


    A television supports many several resolutions and different framerates, unlike a PC monitor that (AFAIK) only support 55-140Hz. But for many 23/24/30fps videos, "Sync playback to display" is still recommended. My TV gets hiccups when that option is not enabled.


    @kanyck

    Having a big a$$ cache buffer has nothing to do with the above problem. I have never used a big cache on my system. IMO, such a cache is only good for when you have a totally crap internet connection while watching online videos. If this also applies to watching videos via your own local network, then you have a serious network problem. Or perhaps a shoddy wifi connection is to blame?

  • Klojum

    Must I make use of 4G RAM somehow, mustn't I? :-) It didn't help, anyway. At least I tried it and now I'm sure it's not a cache issue...

    Meanwhile, the connection seems to be perfectly okay, and the same issue appears even on a gigabit LAN. (BTW is there iperf for LE available somewhere? Couldn't find any, and for such a case it might be helpful, at least to be sure). Looks like a driver issue to me...

  • Selecting difrent resolutions and refresh rate that I think are suported in whitelisted didnt help.


    So i downgraded to 8.2.5.


    adjust display resresh rate: off

    Sync playback to display: off


    Cant find whitelisted but resolution is set to 1920/1080p and resfresh rate is 60.

    No playback issues with the same video file.

  • Normally just the setting 'Sync playback to display: Start/Stop' is all I need, it'll then auto switch the refresh rate of the display to match the content.


    (But yes, obviously your TV needs to have 23.96/24/25hz refresh rates)

  • Have the same problem here. Sync playback to display is active and the problem started with 8.90.007, while the previous alpha did just fine. I see it only with tv head input, and it seems that not all channels have the same problem, so I assume it has something to do with the refresh rate of the souce.