WETEK Core - LibreELEC-WeTek_Core.arm-8.90.006 - ir-remote not working

  • I tried my favorite ir-remote on the latest libreelec alpha 8.90.006 but it doens't work.

    When I ssh in the box and I run ir-keytable (after killing kodi and lircevent) I get htis message:

    LibreELEC-core:~ # ir-keytable

    /sys/class/rc/: No such file or directory

    No devices found

    So it doesn't find a IR-receiver. lsmod gives me this:

    LibreELEC-core:~ # lsmod

    Module Size Used by

    hci_uart 19283 1

    bluetooth 272799 2 hci_uart

    8021q 16235 0

    snd_usb_audio 98788 0

    snd_usbmidi_lib 16198 1 snd_usb_audio

    snd_hwdep 4673 1 snd_usb_audio

    snd_rawmidi 15409 1 snd_usbmidi_lib

    dhd 599647 0

    cfg80211 204326 1 dhd

    mali 161146 0

    dmesg | grep meson results in this:

    LibreELEC-core:~ # dmesg | grep meson

    [ [email protected]] mesonfb0(low) : 0x09100000 - 0x0d900000 ( 72 MiB)

    [ [email protected]] mesonfb1(low) : 0x0d900000 - 0x0da00000 ( 1 MiB)

    [ [email protected]] mesonstream0(low) : 0x0da00000 - 0x0fa00000 ( 32 MiB)

    [ [email protected]] meson_serial_console_setup

    [ [email protected]] meson_cs_dvfs_probe, table count:29, use_pwm:1, pwm controller:2

    [ [email protected]] [DVFS]aml_dvfs_register_driver, driver meson-cs-dvfs regist success, mask:1, source id:1

    [ [email protected]] don't find to display_size_default from mesonfb-dts

    [ [email protected]] meson-eth: probe of meson-eth failed with error -1

    [ [email protected]] input: aml_keypad as /devices/platform/meson-remote/input/input4

    [ [email protected]] enter meson_pm_init

    [ [email protected]] enter meson_pm_probe!

    [ [email protected]] meson_pm_probe done !

    [ [email protected]] meson_cpufreq: no voltage_control prop

    Somebody an idea?

  • CvH,

    problem is this:

    /sys/class/rc/: No such file or directory

    No devices found

    What means no ir-receiver is found. If it doesn't find a IR receiver I can't continue with the wiki-page. I already have all files cause I already did it for my Khadas VIM.

    Normally when a IR receiver is found the meson-ir module should be loaded.

    Probably it does have something to do with the kernel as Balbes150 doesn't get the IR working also on his S812 builds (although I don't know the current status of it).

  • Not sure about Wetek Core but IIRC Wetek Play 1 (which should be similar) uses an RF remote - the IR is only used for power up and not available / exposed in Linux.

    So ir-keytable etc can't work as there's no IR receiver.

    so long,


  • Strange,

    I already used it with libreelec and a IR-remote. I never used the rf-remote as it is not a good match with kodi.

    I will check that again with a older version of libreelec.

  • Hmmm. Could be that you need to use this amremote thing then?

    We switched from amremote to meson-ir on the other Amlogic devices, like Odroid C2, Le Potato, ... which run on kernel 3.14. But I have no idea about Wetek Core. Maybe someone else can chime in here.

    so long,


  • HiassofT,

    just tried it with libreelec 8. The IR-remote works like a charm with my remote.conf.

    I know you changed to meson-ir. it's why you need to do the ir-keytable stuff. Previous with amremote it was just copying your remote.conf into /storage/.config.

    See my dmesg from LE8 on the core in attachement as proof:dmesg.txt

  • Are there plans to implement meson-ir in the 3.10 kernel? Or should I open a thread on the wetek forum for these kind of things?

  • With the latest version the remote is working again the old fashion way. Just place the remote.conf of your remote in the configuration map as it was with libreelec 8.

  • roel, im in a similar issue with LE9.0 and a wetek play 1 openelec edition, the remote which is openelec branded is RF and operation in LibreElec is awful. You say its working again the old fashion way ?

    Could you possibly attach the file you are using in /storage/.config/remote.conf

  • I can fully understand why meson-ir is now the new default, but that doesn't mean that it's not bloody awful in regards to current usability.

    The WeTek Play 2 remote for example is almost laughable in how it performs now.

  • Id have to agree Wetek Play 1 is the same. At the very least let it be configurable, i believe coreelec facilitates both

  • To all,

    meson-ir is not enabled on the Wetek core and I assume also not on the wetek play 1. The kernel is to old and I assume they don't want to implement it. IR-remotes still work the old fashion way with the remote.conf. But I assume you guys are talking about the original remote that is RF 2,4 GHz as far as I now, so your problems will be somewhere else. Maybe you should give detailed problems of the remote and start a new thread.

  • Im not entirely sure how LE9.0 IR operates where the Wetek Play 1 is concerned.

    I attempted to create a new remote.conf with a alternative remote, i was able to get the keycode of the alternative remote used

    but i never was able to capture the button press events so wasnt able to populate a file.

    It seems like it was ignoring key presses.

  • I've had a go at the .conf route myself with the openelec box/remote and not had good results. Had to reflash twice. I could live with the limited functionality and use kore for anything I need to do the remote doesn't but the favourites button not working is a right pain.