Slice CM1 update failed

  • I tried to update my slice by copying the Slice.arm-8.2.3.tar to the updates folder using samba.

    I didn't check that it copied!

    When I rebooted nothing happened so I went into recovery mode to put back the old version.

    I get error extracting tarball wget unable to resolve host address updates fiveninjas.com tar.

    I looked for the fiveninjas forum but it has disappeared.

  • More info:

    I can only access recovery mode, Kodi is gone, but I can't recover as it tries to access fiveninjas.com tar.

    I can't see anything using a usb cable.

    I presume this has happened in "the early days" and would be documented on the five ninja's forum which has now disappeared.

    I bought the slice through kickstarter but only started using it recently for music.

  • I am trying to flash the eMMC using the instructions on the Raspberry Pi foundation website but my Windows 7 pc doesn't find the Slice, also there is mention of setting J4, which I can't find, any ideas anyone?

  • It's been a while since I flashed one, but the rough sequence (once you installed the CM drivers to Win7) is to connect the USB cable and wait for that device to be detected, then run the exe file and it detects the device, then power the box on and the memory will mount. According to the Pi Foundation site the exe should run automagically but it never happened for me - I always had to do it manually. At this point if the original Slice image used a FAT partition for boot stuff (it's a couple of years since I saw the original noobs config and I can't remember) it will be mount and you can copy over (overwrite) the boot files from the target folder of the .tar file. If not, the only option will be to flash the eMMC with our .img file which will nuke the existing install .. but the ease the pain of loss you get some extra space on the eMMC as noobs is no longer present. Flashing the eMMC won't touch the internal HDD if you have one installed.


    NB: No idea what J4 is about so definitely not required.

  • Thanks, think I have tried most of that, perhaps not in the correct order, will start again.

    Is it possible to damage the CM?

    Is it worth upgrading to CM3 for audio only use?

  • It's not sure it's possible to damage the CM1 unless you've opened the case and done anti-static nastiness. There's an element of timing and sequence to the flashing process though. It's a bit fiddly.


    CM1 is fine for audio only. If it's works, no need to fix it.

  • its definitely slice with power, this will get you access to flash the image. Without power gets you access to the hdd where you store your videos.


    just keep trying different combinations of powering on and connecting, it can be temperamental. Also change usb ports (maybe an old usb 2 port?)

  • I have similar problem here. I have a Slice box with the original CM1 and Slice OS mounted.


    I would like to upgrade the OS to LibreELEC. I tried to manually update the OS, but current LibreELEC-Slice.arm-8.2.3.tar files from the Download section are broken links. Than I tried to flash the eMMC storage following the instructions on the Raspberry Pi foundation website. Unfortunally, after having installed the driver, when attaching the Slice box to the micro USB, Windows 10 said that new hardware is not recognized and I don't know how to proceed. Any suggest?

  • Is it worth upgrading to CM3 for audio only use?

    nick123456

    I used the CM1 for audio and it worked fine.


    I upgraded to CM3 and the GUI interface and general responsiveness is much better. Worth the effort, I think, as the user experience is much smoother and faster, with less jerky screen / pointer movement. However the CM3 really needs a bit of cooling and a number of folks have "stuck a lump of copper"*** between the CM3 CPU and the case which keeps it running much cooler. Less of an issue for audio, almost mandatory for video.


    If the sluggish user interface (compared with a CM3) is not an issue, I agree with chewitt If it is not broken, don't fix it.


    Roger


    *** Technical term, the actual solution was, in most cases, a little more refined :) (pun intended)