[8.2.5.1] LAN not working, T95Z Pro 912 Box

  • I can't get the LAN connection to work on my T95Z Pro 912 box. I'm running the 8.2.5 build linked from the MEGA folder.


    The box I have is a 2G/16G S912 box with 1000M Ethernet port. I'm using the gxm_q201_2g_1gbit.dtb as my tree.


    The LAN connections works when I'm not booted into LibreELEC, so it's not a hardware issue.


    Any suggestions?

  • Try with gxm_q200_2g.dtb...


    gxm_q201_2g_1gbit.dtb keeps giving me a 169.xx IP address, and setting it manually didn't seem to help anything.


    gxm_q200_2g.dtb results in the device not booting at all.


    gxm_q201_2g.dtb results in the device not even showing the LAN connection, though it shows all the WiFi connections available.


    I've also tried going back to 8.2.4 but everything still seems to be the same.

  • doubleohpsycho

    Changed the title of the thread from “LAN not working, 8.2.5.1, T95Z Pro 912 Box” to “[8.2.5.1] LAN not working, T95Z Pro 912 Box”.
  • With CoreELEC you'd need the 1gbit dtb for a T95Z. But this thread suggests that recent T95Z boxes are using an ethernet phy that the current driver in *ELEC just can't handle correctly.

  • Thank you, Sholander and The Coolest. You guys pointed me in the right direction. I guess the T95Z had a hardware issue or something with the Ethernet port. The information led me to a command to limit the ethernet speed. Everything works now (still fighting to get the VFD working though) with LAN.


    Even though I limited the ethernet to 100M, I'm getting faster than 100M speeds and can now stream files without buffer/stutter. So all seems to be well.

  • Thank you, Sholander and The Coolest. You guys pointed me in the right direction. I guess the T95Z had a hardware issue or something with the Ethernet port. The information led me to a command to limit the ethernet speed. Everything works now (still fighting to get the VFD working though) with LAN.


    Even though I limited the ethernet to 100M, I'm getting faster than 100M speeds and can now stream files without buffer/stutter. So all seems to be well.

    how do you solve this problem? I have a M8s Pro "912 1gbit 3gbddr4. In the LE settings there no Ethernet option.. so the sasme problem.

    which device tree I should use?

    Im on 8.2.5

    sam problem on 8.2.2.3