Kodi 18.0 Update for Slice.

  • Hi,

    I've just used the standard built in update process to update to Kodi 18.0-BETA1 (8.90.004) on my Slice.

    Everything that I use seems to be working great, it's even got the latest HEVC updates, so is playing HEVC very well.

    Thanks to everyone involved and Chewitt for compiling it up for our box.



  • Thanks, that's good to know. I'm not due much credit though .. it's all working nicely due it being an RPi in disguise.

    CvH if you need a tester for the 005 alpha while I'm on vacation! ;)

  • Hi, it would be nice if someone could confirm that the images (they are the release images) for Slice/3 are working.


    Was running 8.2.5 ; I downloaded and saved the ...slice.arm...img.gz file (CM1) into .update folder; rebooted; found update and installed OK; reboot..... now I can only get

    Error in mount_flash: mount_common Could not mount  /dev/mmcblk0p5

    Have been searching and trying various things, but no luck.

    I still have the slice noobs, so should I Flash LibreELEC to internal eMMC storage?

    EDIT: I finally pieced together various howto sources and was able to reflash eMMC with the 8.90.005. Seems to work. But I have other set-up and problems to work through getting back to the previous state of functionality.


    Edited once, last by okichatan ().

  • Thanks, that's good to know. I'm not due much credit though .. it's all working nicely due it being an RPi in disguise.

    CvH if you need a tester for the 005 alpha while I'm on vacation! ;)

    You had to include the extra bits for our LED's and the analogue audio chip (which works, I've tried it through my HiFi). :-)

  • Hi,

    I have found a problem. If I play a reasonably heavily compressed HEVC file, which is dark, I'm getting green and purple blocks, almost exclusively on the right hand side of the screen, mainly down the edge, but up to a quarter of the way across the screen, playing the same file using Milhouses RPi2 test build 20180730 #0730, it's playing fine on my test Pi3. I've updated to Milhouse build 20180918 #0918 and I now get the coloured blocks on Milhouses build, so I'll report it in the test build thread.

    Photos of the problem here. https://www.dropbox.com/sh/nht0h53eqdsz8...8Uwba?dl=0


    PS. This is now fixed on the test builds, so hopefully will reach us in due course. :-)

    Edited 2 times, last by bleep42 ().

  • My lovely slice has started to get wonkey

    I am lookng for the latest development builds


    Its seems to reboot lately and get stuck on updating the database with new music recordings


    Edited once, last by sparkplug ().

  • Debug log files that demonstrate the problem will provide more info that your "wonky" description. I'm not doing any development specific the the Slice these days (as none is required) but next Alpha release will be out imminently.

  • Thanks for the help Chewitt I found that the log files had filled up the available memory. deleted them and all is happy!

    Using the latest pre-release fork

  • anyone else noticed that video calibration settings don't survive restart?

    I noticed it first on 8.90.005 and issue is still present in 8.90.006...

    8.90.007 is still not visible for my Slice somehow...

  • Hi CvH,

    I've tried out 8.90.008 and everything I've tried works fine, video (H264 & H265), audio playback, Analogue audio and LEDs all working well. :-)



  • Installed 8.90.008 (upgrade from V17) and most everything seems OK.

    My problems FYI:

    1) My Harmony 650 Remote “guide” button now causes a PVR error, not the “Context Menu” like before. I'll need to research this more. (EDIT: installed/used Keymap app to fix the button)

    2) Because I upgraded from V17 (or I goofed something else up) my library didn't get retained. So I just rescanned my library.

    Thanks for keep this old Slice (CM1) up and running!

    Edited once, last by okichatan: added resolution about remote ().