LibreELEC 8.x images for additional dvb drivers

  • CvH got a day off tommorow so can mess about with this abit more, i changed code abit to

    Shell-Script
    1. #!/bin/sh
    2. dvb-fe-tool --adapter=0 --frontend=0 --set-delsys=DVBC/ANNEX_A


    reason being cable one is showing as adaptor 0 and sat as adapter 1. not sure if that correct or not
    cable tuner shows as dev/dvb/adaptor0/frontend0
    terrestrial tuner shows as dev/dvb/adaptor0/frontend0
    sat tuner shows as dev/dvb/adaptor1/frontend0


  • got a day off tommorow so can mess about with this abit more, i changed code abit to


    I can not really help because I have zero idea about that - all I know if from mr google about that ;)
    Maybe I need to build the dvbsky closed source driver - idk whats change there.

  • hopefully this might help, someone had it working on ubuntu 2014

    Code
    1. i have the same card working with ubuntu 14.10, kernelversion 3.16.0-23.
    2. i followed the guide from dvbsky.net ([url=http://www.dvbsky.net/download/doc/Linux_Driver_installation_en.pdf]http://www.dvbsky.net/download/doc/L...llation_en.pdf[/url])
    3. i genereated the channels.conf with w-scan (wiki.ubuntuusers.de/w_scan).
    4. So, now you have to know, which DVB you want to use:
    5. DVB-S is adapter0/frontend0
    6. DVB-T is adapter1/frontend0
    7. DVB-C is adapter1/frontend1


    in his, frontend is different for dvb-t and dvb-c so might work with

    Code
    1. autostart.sh


    . as at the moment on mine tvheadend is showing same adaptor and frontend for dvb-t and dvb-c.

  • LibreELEC-7.0.1 dvb-drivers-1.2 released:
    * new official TBS open source drivers (TBS6205, TBS6904, TBS6909) - more to come
    - latest crazycat
    - latest media_build (4.6)
    - latest ljalves-cc
    - dddvb 99% broken I think - still need to find the problem


  • Great work! But my TBS5881 is still not working in the RPI, now I saw in dmesg that dvb-usb-tbsqbox-id5881.fw is missing at /lib/firmware/


    [ 6.222150] dvb-usb: found a 'TBS 5881 CI USB2.0' in cold state, will try to load a firmware
    [ 6.248817] usb 1-1.3: Direct firmware load for dvb-usb-tbsqbox-id5881.fw failed with error -2
    [ 6.248853] dvb-usb: did not find the firmware file. (dvb-usb-tbsqbox-id5881.fw) Please see linux/Documentation/dvb/ for more details on firmware-problems. (-2)


    How could I add it to see if the tbs5881 works? At 7.0.0 there was not this problem


  • Great work! But my TBS5881 is still not working in the RPI, now I saw in dmesg that dvb-usb-tbsqbox-id5881.fw is missing at /lib/firmware/


    damn forget to put the fws in there ....
    reuploading 1.2 .. pls redownload them and update


  • LibreELEC-7.0.1 dvb-drivers-1.2 released:
    ...
    - dddvb 99% broken I think - still need to find the problem


    yes, it doesn't work. Here are the logs.
    Big Thanks for working on it!

    Files

    OS: LibreELEC-Generic.x86_64 (Milhouse) [Build #1207]
    HW: Asus F1A75-V EVO | AMD A8-3870K | Digital Devices Cine C/T V6

  • Would be good to have these modules as one or more addons (preferrably one for each set).


    What needs to happen to make that a reality?


  • Big Thanks for working on it!


    thankfully mmajoor had an idea how to make it work - at least it is working for him - maybe for you too
    pls have a look if testimages is working (you have to re-set you driver at the settings addon)




    Would be good to have these modules as one or more addons (preferrably one for each set).


    Sry I have no idea from what are you talking about ;)

  • Hey CvH now I tried latest version and it is also not working, it is all about drivers [emoji16] [emoji379]


    Do you have any idea of what could I try? Perhaps cross-compile official drivers or something like that


    I wrote crazycat about this but have no luck

  • It seems to load OK, but it does not tune


    Tvheadend output at scanning:

    Code
    1. 2016-05-29 13:47:48.494 mpegts: 375MHz in MC - tuning on Silicon Labs Si2168 : DVB-C #0
    2. 2016-05-29 13:47:48.494 eit: registering mux 375MHz in MC
    3. 2016-05-29 13:47:48.657 subscription: 0001: "scan" subscribing to mux "375MHz", weight: 5, adapter: "Silicon Labs Si2168 : DVB-C #0", network: "MC", service: "Raw PID Subscription"
    4. 2016-05-29 13:47:53.602 mpegts: 375MHz in MC - scan no data, failed
    5. 2016-05-29 13:47:53.602 subscription: 0001: "scan" unsubscribing