remounting partition on sdcard

  • Hi there,i have a problem and google has not been helpful.
    (and yes, i did try google first, because i sure someone will say "try google")

    I have a 119GB microsd card divided into 3 partitions:
    1)boot(fat32)
    2)setting(ext4)
    3)Media partition(Ntfs)

    for some reason (3) is being treated as a system drive as in read-only, and i cant find the file that controls this behavior and fstab is empty as well
    so, how can i get (3) to be read-write instead of read-only?

  • I'm just curious... Did you create those partitions manually just right of the bat onto the SD card, or did you create the 3rd NTFS partition after a completed LibreELEC installation via a LibreELEC image?

  • it was after installation, using gparted to shrink (2), i had to used windows to make and format (3) since i tried with linux and it was.......corrupted when windows tried to see it.

  • Perhaps exFAT works better than NTFS. But also EXT4 is a default linux disk format for several years now. So why not use that for your media partition as well?

  • while i know how to use linux, windows is my primary OS. that and i manage most of my drives like (3) thru windows as well. i had forgotten about exFAT, i can try to see that will work. however, i would like keep NTFS if possible.

  • I know it's not the real answer but...

    I'm assuming from previous threads, you've got a Cubox-i4


    If that is correct, your simplest and "best" solution is to buy a $20 eSata caddy combined with a 120GB SSD - this attached to the Cubox eSata connector will give ~ 3Gbps (Max) - much faster speeds than a SD card.


    I've never tried but "It might work" - setting the 2nd partition to NTFS so "settings" ie /Storage is the rest of your SD card.


    LE will generally mount non system files as RW, so not too sure what is going on.


    Can you provide (as detailed in my signature) a full Kodi debug log , a dmesg (via paste) and the output of "df -h" and "mount"

  • Iridium , you're in the right family product, the model im working with is cubox-i2exw.

    for the kodi.log :

    dmesg:


    output of "df -h":


    and mount:

  • i think i figured out why it mounts it as read-only....

    when i'm in windows, i didnt use the "eject safety" option on the sdcard marking "dirty". once i "safety" removed the sdcard, mount shows it as rw instead of ro

    however, even with rw, i can't delete any videos( or make new directories from ssh/samba), why?

    Edited 3 times, last by Animejin ().

  • Dmesg certainly shows an error mounting.


    [ 12.697901] ntfs: driver 2.1.32 [Flags: R/W MODULE].

    [ 12.707433] ntfs: (device mmcblk0p3): parse_options(): Option utf8 is no longer supported, using option nls=utf8. Please use option nls=utf8 in the future and make sure utf8 is compiled either as a module or into the kernel.

    [ 12.794279] ntfs: volume version 3.1.

    [ 12.796701] ntfs: (device mmcblk0p3): load_system_files(): $LogFile is not clean. Mounting read-only. Mount in Windows.


    1) Are you sure you have "Settings --> Media --> General --> Allow file renaming and deletion" set

    2) Provide log files after you try to make new directories via ssh/samba.

  • WOW: Just realised that you're running LE 7.0.2 - is there any reason why you haven't upgraded?


    I've replicated your setup (Albeit on 8.2.5) of 3 partitions. (2 LE) and one NTFS and everything worked as expected - /dev/mmcblk3 was mounted as RW at /var/media/NTFS and I could read,write and delete. So something seems to be happening at the Windoze level.


    Do you really need to manually use the SD card to transfer data when SFTP or Samba will do the job over the network?

  • to answer your question, i did have problems with the higher versions, so 7.0.2 was more stable at the time, i haven't tried to upgrade in a while.

    yes, i used windows because it can transfer over 2-3 times faster of youtube videos or anime or movies much faster than a Samba or SFTP connection could, (avg sizes: 1 GB - 5GB from time to time)

    Edited once, last by Animejin ().

  • well, upgrading seems to have fixed the issue. i just hope i wont experience the same problems as before....