Autosubs problem

  • I have a library of 4K HDR movies and autosubs is causing problems. When I click the movie title it changes display to HDR and then just goes back to main menu without playing movie. I get a black screen for a second.


    After that it never plays that movie again until i go into the movie folder and manually delete the subtitles in the folder of that movie and disable Autosubs.

  • Hm, I just posted my answer to a similar question in another post, so I'll copy it here:


    I believe it's a bug in the 8.2.4.X version.


    It happens where you try to play a movie that is in a folder shared on the network by SMB (Samba).


    I've seen 3 possible solutions:

    1. (the easiest which is what I do) Use network sharing system NFS instead of SMB

    2. Something about storing the subtitle files in a special subtitle folder, separate from where the movie is located. You'll have to search the forums, I don't remember exactly how that works, but theres a libreelec setting about subtitle folders I think.

    3. Something about the "Version" of SMB. Apparently SMB has versions which is an advanced setting. I've also seen this somewhere in the folders but I'm not sure if it's an advanced setting of Libreelec, or where the movie is located (like a Windows setting, or a NAS setting)

  • Well NFS doesn't work for me in Windows and it appears it's not a Autosubs problem as you said too.


    Guess I'd have to look into storing it in seperate folders.

  • Yeah I tried winnfsd but it doesn't want to start on my PC. Whining about port daemon not starting. Haven't tried the haneWin one yet that would probably work.


    But I think my problem is fixed after im storing the subtitles in a different location at the android device itself instead of where the SMB share is.


    Thanks DrNicos.