• First of all let me make it clear that im not an expert nor dev on anything linux or it related, more like an advanced user willing to learn if needed.

    Ive been tinkering the last few days with the LE image at


    and while i know its pre pre pre alpha im very happy with how much this LE build has grown, its working pretty well for the use i give it and its mostly stable, but i have to report 3 issues, not as a complain but as an end user tester willing to help improve the build and/or test new things suggested, in order of importance (IMO):

    1 - randomly and specially when pausing or stopping a runing video the kodi interface dies and never come back, but the underlaying OS keeps runing as i can ssh to it and order a reboot or do other stuff normally, this is not a rare occurence, this happens about once of five times i pause or stop a video

    2 - on 2 occassions i got kernel panics but i was unable to pinpoint the cause, on both occassions i was navigating the kodi interface, once setting an addon (that on a second try worked fine) and the second setting kodi to my taste

    3 - i cant make my usb wifi card to work, its an archer t4uhp based on the rtl8812au chipset, some time ago i tested the same card on armbian on the same device and it was working perfectly so im completelly sure that the linux driver exists and its stable, i did some tinkering about this issue and i got some info:

    a- if i do "modinfo 8812au" i get a lot of info so the driver is there but i dont see my specific device ID on the list (2357:010f as seen here)

    b- when i do an "lsusb -t" i get an "Class=Vendor Specific Class" wich i think its generic for "i dont know what is this device")

    c- "modprobe 8812au" does nothing but if i understand the process correctly its normal as the modinfo dont list the device so its not even trying to activate the device.

    And this is where all my knowledge on device drivers ends

    Im willing to try anything to test the build and help improve it, and let me insist that im not complainig at all, in fact im very VERY happy with the build and all the hard work you guys are doing here...

    TLDR: i found issues with the rock64 LE pre alpha build:

    1- kodi randomly dies when pausing or stopping a video (but not the OS)

    2- super random kernel panics

    3- need driver for the usb wifi card Archer t4uhp (chipset rtl8812au (device ID 2357:010f))

    Thanks for reading and any help is totally wellcome :D

  • Another weird thing im seeing now is that if i install a torrent client and if i leave with default settings when i download something most of the time it crashes, only thing i see that can control the crashes is lowering the number of opened connections to 20/30 (also with torrent with low number of peers/seers ofc dont fail no matter if i leave it at the defaults (usually 200/300)) but as the only other network card i have is not being detected i cant test if its a network card/driver issue or an OS issue...

    I tested all this with both transmission (dockerized only) and deluge (both dockerized and native (using the one on thoradia repo)), both dockers from lsioarmhf so imo they are trustworthy...

  • Extra information, no idea if it can help at all or not, the armbian image for this device includes the driver with the correct ID out of the box, no tinkering needed at all...

  • ping CGarces is that device ID in the 8812au driver?

    Sorry for the delay, I not visit the forums since some time ago.

    That device ID not is included in our builds

    But the id exist on some other repositories. I'm not sure if this is compatible with 3.x kernels:

    rtl8812au/usb_intf.c at master · yahont/rtl8812au · GitHub

    chewitt You need a PR for this ID over the current repository?

    TrashCanMan You have free time to test some ideas for rtl device drivers?

    Edited once, last by CGarces ().

  • CGarces I've not been tracking the status/state of RT drivers for some time. If adding the missing ID works please send a PR

  • The device is detected now with the latest kwiboo test build and im not crashing anymore (altho it connects at 2,4ghz for some reason even if at a few cm from the router but it connects and all is fine)

    TYVM for all the help :D

  • Ok some final notes, with the rtl8812 now my rock64 is rock solid (pun intended) and i managed to make it work at 5gz (it was a problem between the chair and the keyboard) so there is either a problem under medium/heavy load with my network card or the driver/os, im open to try things if anyone is curious where exactly the problem is and if it needs a solution on the rock64 image (i have a spare microsd i can use to test stuff up)

    Also googling around i saw that the very first rock64 dev board released had ethernet problems solved after that, can i have one of those boards maybe? i bought mine from a reseller about 8 months ago...