LibreELEC-RR 9.x [ Emulationstation | Retroarch | Pegasus | DolphinQT | Moonlight | Chrome | Spotify ]

  • At first congrats for your great work


    I have a problem when playing any video, from any video addon (i use mainly placenta & elementum). When the video starts it is ok but when i download a subtitle and return back to the video i hav some artifacts in the bottom of the video and some times in the right side. It is like been a part of background. I made a video calibration in order to stretch slightly the screen to wards these sides but no result.


    Do you have any suggestion?


    Thank you

  • Beside the fact that this is most likely a Kodi 18 related problem which is after all still a beta version and here supported Kodi Community Forum you're asking for support of banned add-ons.


    Forum Rules


    https://kodi.wiki/view/official:forum_rules/banned_add-ons


    /shrug

  • I've talked to Escalade about it and he told me he uses docker to realise it and it works quite good. But since I have moonlight embedded included and an Nvidia GPU in my desktop system I can also play every game I want on my generic & RPi based systems./shrug

    please, can you share a tutorial how to do that, i try it couple of time and didn't work for me. thank you.

  • curious as i want to nail a small potential problem on my end for amiga from the start, espically since now that im getting to it (got tied up all of uyesterday an dmost of today) 5schatten kickstart roms,

    NZHeqfU.png


    or

    iYWLJZg.png


    and yes its from my own legal copy of Amiga Forever 7 R2

  • Spotify is not working on fresh install with latest file.

    Keep getting "first time you are starting Spotify ..."

    Any idea how to solve this?

  • Spotify is not working on fresh install with latest file.

    Keep getting "first time you are starting Spotify ..."

    Any idea how to solve this?

    The arch linux repo (https://aur.archlinux.org/cgit/aur.git/plain/pkgbuild?h=spotify) reports version 1.0.88.353 (pkgver=1.0.88.353) but the spotify repo (Index of /pool/non-free/s/spotify-client/) only lists the new version 1.0.89.313 (spotify-client_1.0.89.313.g34a58dea-5_amd64.deb) so basically the arch user repo needs to bump the version and then the download & installation should work.


    It's already flagged as out of date AUR (en) - spotify so I guess it shouldn't take too long until it works again.


    Cael

    I'm going to rework the start scripts for amiberry & fs-uae to get rid of hard coded kickstart rom names. You can then edit the default config files and add the kickstart roms you wish. This script loads either a A500 or a A1200 default config witch contains the rom name. For example kickstart_rom_file=$(FILE_PATH)/kick34005.A500.rom is the default for A500 & this kickstart_rom_file=$(FILE_PATH)/kick40068.A1200.rom for A1200.


    Read the FAQ about the Amiga Kickstarts (bios) and section X. about the configuration. These settings are mandatory for Beta 06.


    valireality


    Well I have no working docker based steam setup so I can't support this right now. Also I use moonlight to play steam games on my HTPC so for me personally it's not necessary. But maybe you can donate escalade some beer(s) and kindly ask about this topic and if he's willing to share his knowledge with us.

  • Beta 06 is online:

    • updated to latest LE9.0 upstream
    • updated generic kernel to 4.18.8
    • updated Samba to v4.9.0
    • updated nano to v3.0
    • updated xf86-video-amdgpu / xf86-video-ati to v18.1.0
    • updated xf86-video-intel to git 25c9a2f
    • added workaround for libretro-mame2016 -> added libretro-database to scrape games
    • reworked fs-uae start scripts & configuration -> read the FAQ
    • added fs-uae support for Interchangeable Preservation Format (.ipf) -> delete your es_systems.cfg before you update
  • ok 5schatten now i know somethisng not really Right, Willy beamish the WHDLoad i get the "Boot-install" screen *something patch failed", the screen fades to black and ifi turn on status bar i can see CPU/HDD is looping (boot loop)


    is the Update .img complete to where i could use it to flash to a test mSD? or do i need a spefic vers of LibreElec then update that way ? as best case scenario my Configs w/ Amiberry are somehow Broken/corrupt. worst case? i gotta recopy all my roms back over from a fresh -re-install on it.

  • Cael

    Change to your Amiberry directory and clean up all files in whdload/save-games so basically delete all files that have s similar name as a game and also delete the files located in whdload/save-games/kickstart


    Also post the amiberry.log located in /var/log


    The problem is that Amiberry creates several files and won't update them. So if you change something like paths or configs it will screw things up. Shouldn't happen again in the future but unfortunately can happen because I reworked the whole start and config stuff.


    I've tested Willy Beamish lha and Syndicate as zip so it should work. I once had a bootloop because I renamed the Kickstarts but the symlinks pointed to the old files so I guess that's your problem too.

  • theres no log there atleast for Amiberry

    BzSNu3b.png


    nor in (smb share/Logfiles)


    as for where to delete said files all i can remotely find is in Configfiles/amiberry/whdboot there was nothing but "Foo.txt" in Kickstarts but i removed the configs in savegames and debugs

  • Well if you've updated to Beta06 there is always a log file because the start script will always log what kind of game you're trying to boot, what kind of Config is loaded and stuff. But of course you have to start your system, run amiberry and then look for the log file, if you restart and look for a log you have to run amiberry again.

    Starting "Adventures Of Willy Beamish" should look like this:

    Code
    1. Kodi already frozen, nothing to do.
    2. Powering on HDMI with explicit settings (CEA mode 19)
    3. Trying to boot this game: /storage/roms/amiga/Testing/WHDLoad/Adventures Of Willy Beamish.lha
    4. Loading a WHDLoad (.lha) file...
    5. Loading Amiga 500 config.
  • log looks exactly like yours Minus HDMI Line, i doubt it has a Single impact but want me to try over an HDMI Connected Display?

  • The HDMI line only applies if you have a TV in CEA mode that does not run at 50Hz. How long do you wait for the game to start? If you have no patches for the game I guess it's normal to see failed patches or something like "set patch failed". It takes about one minute to boot Willy here and about 1:30 if you start it the first time on a RPi 3B and so it should take the same time at your system.


    Do you have these files (symlinks) in your ~/.config/amiberry/whdboot/save-data/Kickstarts directory?

    Code
    1. raspi3:~/.config/amiberry/whdboot/save-data/Kickstarts # ls
    2. foo.txt kick34005.A500 kick39106.A1200 kick40068.A1200
    3. kick33180.A500 kick37175.A500 kick40063.A600 kick40068.A4000

    And ~/roms/bios/Kickstarts looks like this?

    Code
    1. raspi3:~/roms/bios/Kickstarts # ls
    2. kick33180.A500.rom kick37175.A500.rom kick40068.A1200.rom
    3. kick34005.A500.rom kick39106.A1200.rom kick40068.A4000.rom


    Works for me on two RPi 3 systems by the way /shrug

  • this might be the point of Failure. (symlinks) all thats there is foo.txt how do i go about making proper symlinks?

    and yes here's my kickstart directory in /roms/bios/Kickstarts
    T2vAxdW.png


    even md5 hash verified i had the correct ones too.

  • Amiberry creates the symlinks itself. It looks for *.rom files in ~/.config/amiberry/kickstarts So just delete the files in ~/.config/amiberry/whdboot/save-data/Kickstarts and try again. Can you use Was ist WinSCP :: WinSCP ? It shows you broken symlinks as red files & it's easy to delete the links if needed.

  • Amiberry creates the symlinks itself. It looks for *.rom files in ~/.config/amiberry/kickstarts So just delete the files in ~/.config/amiberry/whdboot/save-data/Kickstarts and try again. Can you use Was ist WinSCP :: WinSCP ? It shows you broken symlinks as red files & it's easy to delete the links if needed.

    yep they were all Red.
    *edit* after fixing that it worked. looked like it was incorrectly looping due to broken Symlinks.

    now i dont know if this is more less remenants from yoru default or part of the whdload package, willy beamish will play just fine on a default A500 config @7mhz but gets more responsive at 14mhz

    and i got one tiny cosmetic issue for myself and its noit the fault of your build in any way... now awhile back i said i was using an old crt tv.. a boob-tube as it were in my "Retro man-cave" this tv is all fine n dandy except its always had a positioning problem. (outside that its got nice picture quality, front A/V in 2 + a Headphone out jack , Rear A/V in 1 and S-Video in)
    i've fixed it in Kodi. but i need to for things like retroarch/emulationstation launched emulators.

    i'll attach images in a sec, my good phone's charging from a dead battery so quality wise its gonna be New 3DS poor.


    UWp2oRJ.jpg

    FmmFkYU.jpg


    its like this a tad on all sides, any suggestions how to adjust for this?

    Edited 3 times, last by Cael ().

  • I only load the default config files at WHDLoad because otherwise the resolution / or the image could be wrong placed. But everyone has to adjust the default files for their needs if it comes to resolution and stuff, they are just "templates" with working, but might imperfect working settings. For the games itself the default configs only apply if you load any game beside WHDLoad.


    For WHDLoad itself amiberry looks for game specific settings in the whdload_db.xml WHDLoad Auto booting · midwan/amiberry Wiki · GitHub so if you want to run a game with diffrent settings you have to change the whdboot/hostprefs.conf but thats something you have to adjust for yourself because that's highly individual. I guess the Amiberry wiki is quite good for a start.


    I guess you can correct the edges of your tv in your tv settings look for geometry settings since these can correct image flaws. Google for "crt geometry corner convergence" I guess this could be handy.

  • Hi there.

    I really love this release. I've actually wanted this for a long time, but now I know it exists. It did take some tinkering to get the sound to work, but now I am all god.

    I do experience some stuttering on gamecube and ps1 games, which I honestly think should not be there. I am running the generic x86 build on my NUC I5, 7th. gen. Gamecube and PSX one games seem to run at 100% speed, but sometime it stutters. I would be more inclined to accept a general slow perfomance as an indicator for my pc not being fast enough. Can anyone explain or help with optimizing tips.