LE 9.0-devel for more Hardware (Gemini / Coffee / Cannon / Ice Lake, AMD Vega / Raven APU) and luks, lvm2, dm-raid

  • Yippie, a Ryzen 5 2400G working Image, you got it, many thanks for this!

    Blade Runner 2049 4K is running at about 10% CPU, so Hardware Acceleration works fine.


    Hardware: Ryzen 5 2400G, Arsrock Fatal1ty AB350 Gaming-ITX/ac Bios 4.6.0, 8GB RAM, Samsung NVME SSD.

  • Sorry, I didn't get any notifications there had been new posts in this thread.


    Yes, looks like Python is crashing.


    The complete source of my build is included within the tar file - there's a file called milhouse.build.0610.tar.gz within the tar file, if you extract this and then extract the contents you'll have all my build scripts, and the configuration for the build, plus all the patches. If you extract the contents of the milhouse tar, cd to a "clean" LibreELEC repository, then run <milhouse tar contents>/config/reset.sh it will apply all of my patches to the repository.


    Fortunately it sounds like you've now got a working build - I've lost count of the number of clean builds I've had to make over the last week! :(


    I've started looking at a new mainline 4.17 kernel for Generic, with AMD DC support - the branch is here: Comparing LibreELEC:master...milhousevh:linux4170 · LibreELEC/LibreELEC.tv · GitHub - I may pinch some of your commits. :)


    I'll post a link to an initial 4.17 build later, as it would be good to get feedback from AMD GPU users.

  • Thanks and working well so far on my NUC7PJYH


    Edit: spoke to soon it looks like I have the refresh rate switching issue without the i915.glkhdmi=2 patch

    OK I'll see about it adding it in my branch - thanks.

  • HiassofT

    You can see what i have changed from the git checkout in my release posts. The 2 you want to look are #26 and #29. They are both running fine in short test without crashing kodi.

    Thanks a lot for the info! Glad you got it working and that there doesn't seem to be an issue with gcc 8.1.


    so long,


    Hias

  • The Build from sky42 #35 works on my Asrock Board with an 2400G, what Board do oyu have? Latest Bios installed? UEFI Settings?

  • milhouse

    My kernel config for AMD DC is different than yours


    Quote

    Choose this option if you want to use frame buffer compression support. This is a power optimisation feature, check its availability on your hardware before enabling this option.


    i am not sure about that one and it is off

    # CONFIG_DRM_AMD_DC_FBC is not set


    Quote

    Choose this option if you want to have Raven family for display engine


    and this need to be on

    CONFIG_DRM_AMD_DC_DCN1_0=y

  • Will try the build in #35. It might work. it just doesn't like my tv when running the installer atleast as my tv insists on no input. Might be showing an incompatible resolution or something. Will try it on a pc monitor first.

  • Workaround might be installing the original Build and using the Update Folder for the .tar file.

    I had a not running instalation on the disk and just using update, this is working on my system.


    Hopefully you are using the latest build from 0:29.

  • The complete source of my build is included within the tar file - there's a file called milhouse.build.0610.tar.gz within the tar file, if you extract this and then extract the contents you'll have all my build scripts, and the configuration for the build, plus all the patches. If you extract the contents of the milhouse tar, cd to a "clean" LibreELEC repository, then run <milhouse tar contents>/config/reset.sh it will apply all of my patches to the repository.


    milhouse i am struggeling to rebuild your #0610b with kernel 4.17. That reset.sh applies both patches and after that it becomes tricky. For the live of it i could not figure out how to build it with all the packages updates, which are not in those patches. Probably i need to create a github account. I tried without.


    That package problem aside, i try to build just with libreelec.patch and project.patch. The first fail is i need a milhouse.buildcode, but that was easy fixable.

    The second one with a clean build


    I had the same problem as i first tried your 00_mesa1811_xorg120_combo.txt patch and then failed back to PR2739 to get Mesa 18.1.1.

    It was fresh checkt out and nothing else than reset.sh followed by make image was done.

    Edited once, last by sky42 ().

  • Thanks, I'll enable the CONFIG_DRM_AMD_DC_DCN1_0=y


    I enabled Frame Buffer Compression as in theory it should increase the effective memory bandwidth - have you had any problems with it?