Experimental build AMD GPU (Vega, Ryzen APU)

  • Hi here experimental build with AMD GPU support


    Sendspace.com Mobile File <-- updated link


    KNOWING ISSUE:
    - popping sound in GUI


    screenshot001.png


    screenshot002.png



    TO TEST on Raven APU


    update 1. - here build with updated mesa, llvm and older Raven firmware

    Sendspace.com Mobile File


    update 2. - here added patch/fix for artefacts (AMD X.Org drivers - Patchwork)

    Sendspace.com Mobile File


    update 3. - shot in blind kernel used in ubuntu with few changes for amd (reported by users as worked)

    Sendspace.com Mobile File

  • link in first post


    this AMD GPU should works in theory ...

  • looks perfect :)




    HW acceleration over VAAPI works :)


  • Thank you very much for your build, I am really excited to get this working, but having an issue installing. Getting this across my screen on install. I have downloaded multiple times and used a few usb sticks.


    I also tried to install another version of LE and dumped the file in the update folder, but when I restarted I got the same line across the Libreelec startup screen, then the system reboots. I am using a ryzen 2400G on an asus b350m-e. Any ideas? I currently have both Windows 10 and Ubuntu 18.04 installed. I am also going through a Denon X2300w to a Vizio P65-C1

  • OK, NOT Working with Ryzen 5 25400G on B350 Mainboard and also not working with AMDA12-9800E on the same mainboard.

    System is going into reboot.

  • KarstenL680 please check pci-ids from GPU - if its "15DD" should work - command lspci on ubuntu or libreleec - if SSH work.

    also dmesg will helpful - maybe some modules/drivers are missing from mainboard. I don't have this CPU/mainboard- so I need logs for try get this working


    also we can try add to syslinux this:

    Quote

    amdgpu.exp_hw_support=1

  • you need over ssh do it this on my LE build


    Code
    1. wget http://lrusak.libreelec.tv/public/modetest
    2. systemctl stop kodi
    3. ./modetest | pastebinit
  • Update: I read a lot of people have same problem with Debian or ubuntu


    if you find time please test


    1. Try this one with Bios Settings also they advised to update bios to latest

    (go to your BIOS/UEFI settings -> Boot settings and change CSM(compatibility support module) to disabled. Save and reboot.)


    2. try this build below - I updated llvm, mesa, and replaces firmware for Raven APU

    Sendspace.com Mobile File

  • I have the same problem. Sorry for what is probably a simple question: how do I apply a tar file to a system that will not boot?