@balbes150 LE images with Kodi-19 for S9xxx

  • it supported K18 when K18 was the focus of development. It switched to K19 some time ago, so there are no longer any K18 images.

    Yes, I understand that.

    I am asking if anyone has kept an image with Kodi-18 form VIM2 anywhere to upload it again.



  • Hi, I'm new here. I want to try libreelec. what image should i use? Beelink GT1 mini 2/32 gb. Thank you for answer.

    Edited once, last by pompo3 ().

  • Latest aarch64 image from 29.01 is relatively stable.

    i've noticed a pattern of random crashes of kodi, when performance governor is applied for cpu and gpu on ugoos am6 (g12b).

    http://ix.io/2Omg -> latest example

    additionally, some random freezes occur (no log in this scenario)

    from time to time I lose sound and dmesg is complaining missing asoc backend for a certain dai link 0;

  • Hi,

    I have downloaded the LibreELEC-ARMv7.arm-9.80-devel-20210126124908-d174eba-s8xx img to test with my Tronfy MXQ tvbox. Results are as following:

    1. Can't boot with the meson8b-mxq.dtb

    2. Successfully boot with meson8b-odroidc1.dtb

    But there is no wifi, no ethernet. With wired I have an IPaddress like 169.254.168.* and I can't ssh into.So can't go deep in my tests because i can't install anything and HDMI-CEC is not working.

    Thanks for yor greet job!!

    Edited once, last by basomele ().

  • Using latest LibreELEC-ARMv8.aarch64-9.80-devel-20210218142340-8bd19d9-amlgx.img.gz works great on my Fiberhome HG680P, only there's no wifi (rtl8188fu/rtl8189fs)

    So can you add rtl8188fu/rtl8189fs wifi module again like previous release (it was working with older release), thanx in advance.

    • Official Post

    Tried both aarch64-10 20210301-amlgx and arm-10 20210301-amlgx but still no luck, no working wifi

    The module is available and loaded normally. I don't have your model, I don't know why it doesn't work for you. Which DTB do you use ?

  • The module is available and loaded normally. I don't have your model, I don't know why it doesn't work for you. Which DTB do you use ?

    Currently using default DTB from AMLGX (meson-gxl-s905x-p212.dtb) or do you have any suggestion?

    My device has two varian, using either RTL8188FU or RTL8188FS, and mine using RTL8188FU which should be working

    I'll try the latest release (20210305) and explore some more, see if there's workaround to make my wifi working,

    thanx for your time and efforts to develop this

    Update : still no luck using latest (20210305) - is it only RTL8188FU driver, or RTL8188FS is also included?

    Edited once, last by draven ().

  • balbes150

    Hello, I have tried yesterday your build for S905 and chewitts one.

    My box is a Beelink M18. I wanted to try whats the difference, as the official one is unable to play Mpeg2 content.

    Your Version does not have working Wifi, as the adapter does not show. And therefore I could not test Tvheadens, which is the main usage of this box.

    Is there a difference in the DTB files?

    I used on booth versions the meson-gxbb-p200.dtb

    back in the days with Libreelec 8.2 I used gxbb_p200_2G_1Gbit_OTG_Port.dtb

  • should I therefore try all GXBB DTBs to find one which could work? Or is this approach without a chance of success?


  • @ balbes150 First of all, thank you for making these images.

    That was the first image with a mainline kernel that ran longer than 5 minutes on the

    Dreambox dreamone (s922x) / deamtwo (s922x).

    The method of reloading the u-boot.ext is ingenious.

    I used meson-g12b-ugoos-am6.dtb with a patched memory line.

    Now that I've finally got a mainline kernel running on the box, I would like to adapt the device tree.

    Unfortunately, I still have no idea what to adapt to the 5.X dt.

    This is totally new to me. I have the current Dreambox kernel src here: see dreamone.dts/dreamtwo.dts

    A better fitting dt would be very helpful, because the image freezes to death when I play a TS-stream via the enigma2-pvr-addon. I don't know if Panfrost works at all on running TS-streams, but otherwise the image was the best of all mainline tests, All other kernels have already died with a low I/O load or didn't even start.

    And I would be grateful for any tip.

    • Official Post

    _emanuel_ panfrost is used for accelerated GUI rendering and has nothing to do with hardware video decoding. The vdec drivers (which do) are still early work in progress (with not much work in progress). I looked at the vendor keernel dreamone/two dtb files and apart from IR keymaps, LED and button things, there's not much to improve upon with a dedicated dtb - you can build off the W400 dtsi the same as the existing Ugoos AM6 and various Beelink G12B devices (GT King would be a good match). The mainline kernel also takes RAM size from u-boot so this does not need to be set. What do you think is missing?