Wiki: Infrared Remotes for RPi

  • Wiki


    In section for LE 9 it states


    "Change dtoverlay=lirc-rpi to dtoverlay=gpio-ir in /flash/config.txt to switch to the newer gpio-rc-recv driver"


    However in section "Supported Devices - GPIO receiver on RPi" it states

    dtoverlay=gpio-ir

    Surely for LE8 it should read:

    dtoverlay=lirc-rpi


    Is this just a typo?


    I tried dtoverlay=gpio-ir on my RPi3 and my Harmony failed to work, changing back to dtoverlay=lirc-rpi and all worked as expected.

  • Starting with LE 8.2 gpio-ir is the preferred/officially supported way to handle IR remotes on RPi. lirc-rpi is included as a legacy alternative while people migrate to gpio-ir. LE9.0 doesn't include lirc-rpi anymore.


    gpio-ir has been included in LE for a while, but in LE 8.0 and before the easy userspace configuration (via rc_maps.cfg) didn't exist yet (overriding the keymap eg via .config/rc_keymaps/rc6_mce did work though).


    Which LE version are you using and how does your setup look like? i.e. which dtoverlay lines did you use, do you have Lirc enabled or disabled in LE settings, do you have a custom lircd.conf file, did you add something lirc related to autostart.sh or add other custom configurations?


    If you do a fresh installation of LE 8.2 and just add "dtoverlay=gpio-ir" to config.txt your harmony remote should work out of the box if you configure it as a Microsoft MCE remote.


    so long,


    Hias

  • Thanks. So the wiki is correct.


    I'll give it another go and debug the issue. If I still have problems, I'll start a new thread.