Website and Forum Feedback

Need to flag a website or forum bug, or request an improvement? post in here

    1. Incorrect information on the Amlogic download page 1

      • dtech
    2. Replies
      1
      Views
      121
      1
    3. CvH

    1. What happened to the RSS feed 4

      • connesc
    2. Replies
      4
      Views
      163
      4
    3. connesc

    1. Issue when trying to recover lost password 4

      • louis_nichols
    2. Replies
      4
      Views
      301
      4
    3. louis_nichols

    1. Wrong link on website 2

      • schmecks
    2. Replies
      2
      Views
      531
      2
    3. CvH

    1. censored words 1

      • wolfgang61
    2. Replies
      1
      Views
      631
      1
    3. chewitt

    1. Whole thread/posts trashed instead of only removing "offending" links? 6

      • Hedda
    2. Replies
      6
      Views
      913
      6
    3. Hedda

    1. "Mark All Forums as Read" missing on Android 2

      • Jocke.Sve
    2. Replies
      2
      Views
      606
      2
    3. Jocke.Sve

    1. Forum downtime due upgrades 1

      • CvH
      • CvH
    2. Replies
      1
      Views
      1.1k
      1
    3. CvH

    1. Please enable HTTPS for downloads by default 4

      • ximxxomd
    2. Replies
      4
      Views
      2k
      4
    3. gee_whiz

    1. Thank you 6

      • mattlach
    2. Replies
      6
      Views
      1.1k
      6
    3. mattlach

    1. Spammers 5

      • pajtaz
    2. Replies
      5
      Views
      1.7k
      5
    3. Klojum

    1. Why a "like" has been removed? 5

      • Da Flex
    2. Replies
      5
      Views
      1.3k
      5
    3. Da Flex

    1. How to move thread? 3

      • dr.positron
    2. Replies
      3
      Views
      1.1k
      3
    3. Iridium

    1. Suggestions for the forum 2

      • edjalmo
    2. Replies
      2
      Views
      1.7k
      2
    3. edjalmo

Display Options