Minix U9-H - SSH connection refused even though SSH is enabled

  • I have a fresh install of LibreELEC for my Minix U9-H. I chose a hostname, enabled SSH, then connected to WiFi. I have done nothing else. I then checked the IP address of the unit via the GUI and tried to connect via SSH. Doesn't work. I've tried from multiple machines (both Windows and Linux) and all of them fail for the same reason, despite them being able to SSH to other machines fine. I even tried rebooting the Minix box.


    It's as if the SSH server isn't running or the port is blocked on the unit? I'm sure this is meant to work out of the box so I'm a bit confused.

  • Code
    ssh -vvv 192.168.1.133
    OpenSSH_7.2p2 Ubuntu-4ubuntu2.4, OpenSSL 1.0.2g  1 Mar 2016
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 19: Applying options for *
    debug2: resolving "192.168.1.133" port 22
    debug2: ssh_connect_direct: needpriv 0
    debug1: Connecting to 192.168.1.133 [192.168.1.133] port 22.
    debug1: connect to address 192.168.1.133 port 22: Connection refused
    ssh: connect to host 192.168.1.133 port 22: Connection refused

    Like I said, it's as if the box isn't running an SSH server at all or is behind a firewall or something. Ping works fine. :|


    I tried installing the System Tools add-on to see if I could get a local terminal to try to debug this further but the add-on does nothing when I open it. I guess this build of LibreELEC (8.2.2.3 for S912) doesn't include support for such things.

    Edited once, last by DragonQ ().

  • What version have you installed? You gave no indication.

    Latest adamg builds have a firewall that is on by default (in LE settings), try turning it off.

  • What version have you installed? You gave no indication.

    Latest adamg builds have a firewall that is on by default (in LE settings), try turning it off.

    This one. I did have a quick look for some kind of firewall setting and didn't see anything but I'll try again I guess. Every post I can find on the internet about it doesn't mention such a thing, they all just say all you need to do is enable SSH in the menu (or during setup).

  • they all just say all you need to do is enable SSH in the menu (or during setup).

    Yes - only enable SSH in settings, that´s all

    You got connection refused - SSH is disabled.

    Try a fresh installation and wired network connect


    Another check:

    netcat -vvzw1 192.168.1.133 22


    Output must be something like

    Connection to 192.168.1.133 22 port [tcp/ssh] succeeded!

    Edited once, last by Tim_Taylor ().

  • connection refused would indicate that the ssh daemon was either not running or you have the wrong port but in this case it will be the former, ensure you have it enabled

  • connection refused would indicate that the ssh daemon was either not running or you have the wrong port but in this case it will be the former, ensure you have it enabled

    It is enabled, according to the GUI anyway. Seems like it's just broken. I could try with wired but ultimately this box will be on WiFi so it'd only be a debugging exercise.

    Try a fresh installation and wired network connect

    I cannot "try a fresh installation" because that's what this is. I have literally done the bare minimum to get to enabling SSH access.


    I want to try the new LibreELEC-S912.arm-8.2.4-Subtitles-ff build anyway so will see if SSH works with that installed.

  • Just did another fresh install, this time using the LibreELEC-S912.arm-8.2.4-Subtitles-ff build. Didn't even change the default hostname this time, I literally just pressed Next, then connected to WiFi, noted the IP (I fixed it on the router just in case this time), then enabled SSH (the loading icon appeared for 2-3 seconds then the switch appeared "on"), then pressed Next to finish the wizard.


    It now seems to work. The three changes this term were:


    - Different build

    - Fixed IP on router rather than DHCP

    - Using default hostname instead of a custom one

  • The first fresh install failed in some points - therefore I said try a new fresh install optional using another sd card.


    I installed Openelec and Libreelec many times on raspberry and amlogic items - sometimes a fresh install failed.