Spotify Connect Web


  • Hello Gerben,


    At the moment the service uses the host name as the display name.
    Therefore, in order to permanently change the display name, you must change the host name.


    So if i change the display name on the webserver the hostname is also changed?

  • I just bought a Pi3 and installed LibreELEC 7 on it, Kodi works great and I have 7.1 sound via HDMI (2nd device removes the HDMI audio and converts it to normal jack plugs for my Creative Gigaworks S750 speaker set).


    I installed this addon, it also works great except for the speakers it's using... I think it's only using two speakers and no sub, so 2.0 instead of 7.1.


    What do I need to do to make it play my music on all 7.1 channels (like Kodi does).


    PS. I'm new to Pi and also limited on my Linux knowledge



    PS2. I would also like to amplify the volume the Pi sends out... volume 100 is just not enough, can that be done? (this is also for Kodi)

    Using LibreELEC on Pi3 with a HDMI audio extractor to 7.1 PCM

    Edited once, last by MarcelMAH ().

  • Hi man,


    Just select 7ch output on your receiver. Music sounds much better this way....for Movies switch back to the surround decoder.


    Greetzzz,


    Gerben



  • On what receiver?

    Using LibreELEC on Pi3 with a HDMI audio extractor to 7.1 PCM

  • I installed this addon and configure. Addon is working but sound quality is bad. I use wetek play device. Why sound quality is bad? Very bad. Scratchy.
    Wetek device connected to hdmi to TV. I use TV speakers.

    Edited once, last by BTopbas ().

    • Official Post

    Hello BTopas,


    I don't know why the sound quality is bad with your WeTek Play: I have no WeTek Play to test on. I do however know that alsa is merely summarily configured on LibreELEC (by the way, what version of LibreELEC are you using?). You could try to see if alsamixer (shipped with the multimedia-tools addon) enables you to configure your audio device more appropriately.

  • I using 7.0.2 version. Gui sounds and livetv and movies etc everythings sound is nice. Only when spotify connect addon sound is Scratchy. Now ı installed multimedia tools and check alsamixer.

    • Official Post

    BTopbas,


    Bear in mind that Kodi uses its own audio sink, whereas the addon uses alsa. alsa configuration is quite summary as compared to Kodi audio. alsa and Kodi may not coexist happily.


    I would be interested to know alsa features of the WeTek Play onboard audio.

  • Here is sample. https://www.youtube.com/watch?v=f2pDz1FTQsQ 
    I installed alsamixer but this is console app. I dont family to alsamixer console commands.. And i dont know what can i do.
    Edit: I open console and start alsamixer. Alsamixer have a console gui. I changed settings but still same. Only difference volume. I cant figure out any other difference with playing alsamixer. But i can control volume..

    Edited once, last by BTopbas ().

    • Official Post

    BTopbas,


    I am afraid I can not do much, especially with the scarce information I have and without a WeTek Play to test. I will nevertheless have a look at alsa on LE, and see if there is anything I can improve. This might take a while, though.


    Thank you for your patience


  • BTopbas,


    I am afraid I can not do much, especially with the scarce information I have and without a WeTek Play to test. I will nevertheless have a look at alsa on LE, and see if there is anything I can improve. This might take a while, though.


    Thank you for your patience


    I have a Wetek Play myself, installed LE702 and the spotify addon. I can confirm, there is no spotify sound if Kodi uses the same audio device, and that the sound received via spotify (if Kodi is switched to another audio device) is scratchy.


    If you let me know what exactly you would need to perform a deeper debugging, I am happy to help.

    • Official Post

    Hello!


    I have reworked the addon to build all the required Python packages, rather than lazily copy the spotify-connect-web packaged release.
    This improves the sound quality with onboard audio on my RPi2.


    This however also renders the addon platform specific.


    Here is a preview version for LE8 on RPi2


    Volunteers, please test if this improves sound quality for you, too.


    I am building a preview version for LE7 on WeTek Play, and I will post it in my next reply.