Bluetooth audio stops working after a while

  • Got this same problem, did anyone solve this problem?
    When on HDMI and Analoge sound everything works perfect, problem only with bluetooth sound. After the bluetooth sound did disappear it also does not work on hdmi or analogue.
    Have to restart my rapsberry.


  • Use an external Bluetooth dongle with your RPi


    Nice Joke! My friend, this is a bug who need to be fixed. The onboard bluetooth of the RPi it's already good. Think if yours USB Ports of your PC are not working because of drivers, what you do? You buy a PCI USB adapter? Or you find the drivers? :)

  • Nice Joke! My friend, this is a bug who need to be fixed. The onboard bluetooth of the RPi it's already good. Think if yours USB Ports of your PC are not working because of drivers, what you do? You buy a PCI USB adapter? Or you find the drivers? :)


    "drivers" aren't going to fix the poor on board antenna or limited bandwidth the on board Bluetooth device provides especially when using the on board wifi at the same time.


    Sorry.

  • Bug also present when WiFi off! I think it has more to do with the audio format. Anyone can look in my log which i posted here?!


    [size=-1]Send with much love & Android.[/size]


  • Bug also present when WiFi off! I think it has more to do with the audio format. Anyone can look in my log which i posted here?!


    =-1Send with much love & Android.


    It's true. The bug is present also if the WiFi is off, because I'm using LAN network!


  • Ok.
    Disabled the build-in BCM2835 BT controller in the config.txt
    Put in usb my BCM2045 BT controller
    Reboot


    But under LibreElec 7.0.3 settings > bluetooth > No Bluetooth Controller found
    bluetoothctl list = empty


    Is my BT Stick not compatible?


    Found a "Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)" Stick under my couch! Is working now, YEAH!


    Send with much love & Android.

    Edited once, last by Cris_ ().


  • I had the same issue, tried the suggested workarounds - no success,
    I tried the following: setting the "Keep Audio Alive" to "10 minutes" in "System"--> "Settings" --> "Audio..." Don´t set it to "Always", doesn´t work, tried it.
    Now I can listen for an extended period of time... still waiting for the drop out... fingers crossed.
    Hope that helps, as this Pi 3 is a nice system and crappy bluetooth hardware would be very stupid.

  • I had the same issue, tried the suggested workarounds - no success,
    I tried the following: setting the "Keep Audio Alive" to "10 minutes" in "System"--> "Settings" --> "Audio..." Don´t set it to "Always", doesn´t work, tried it.
    Now I can listen for an extended period of time... still waiting for the drop out... fingers crossed.
    Hope that helps, as this Pi 3 is a nice system and crappy bluetooth hardware would be very stupid.


    Does it work correct now?
    Kaois are You still fighting with the raspberry bluetooth or working on a dongle?
    I have ordered a bluetooth dongle will check it out.


  • Same here. I use Logitech BT Adapter that is connected to my amplituner.


    Got the same BT Adapter.
    Im trying with the external bluetooth and still got the same problem.
    How should I configure the system to be sure the bluetooth that im using is dongle not internal? :)

  • In /flash/config.txt


    add the link line:
    dtoverlay=pi3-disable-bt


    Reboot.


    Send with much love & Android.

    Edited once, last by Cris_ ().

  • Hi, suffering from a similar problem here. At work so I can't post a log file, but these are my symptoms:


    Hardware and config: Pi 3 with ethernet cable via homeplug, internal wifi off via LE config screen (how can I tell it's really off?), internal bluetooth enabled. Latest LE (8.0.1).
    Headphones are these:


    Bluetooth Headphones, Orinsong Bluetooth 4.1 Wireless: Amazon.co.uk: Electronics


    Turn headphones on, boot up, sometimes they are already connected, otherwise I need to go into the set up and reconnect them. Make sure audio is set to PULSE audio out, I haven't tweaked any other setting like downmixing. Play a media file from my NAS, it works fine for a few seconds then I lose sound and usually the picture breaks up too. Press stop, start, the picture is jerky and unwatchable, still no sound. I reboot, try the same video, no sound at all and the video stutters severely. If I turn the Pi completely off, wait a few seconds and start, then all is well until I start the video, same issue then. If I change the audio output to HDMI and play the video it works perfectly.


    I'm sitting a metre away from the Pi all this time. I can't believe it's due to the "weak" strength of the internal Pi BT chip due to the symptoms above, it's far more likely to be a software issue.


    Any recommendations? I don't want to get a USB dongle for the Pi as I reckon this is a LE issue and I'd end up with the same problems. Looking at one of those BT dongles you can plug into the TV headphone out socket in the meantime but this just seems a little OTT.

  • So I am dealing with this same issue, I have found that playing an file lower than 1080p it plays almost without any issue. Has anybody found a solution to the audio dropping and frame rate stuttering with PULSE audio?

  • Hilarious that people keep posting asking for a solution when the solution has already been posted. Buy a USB Bluetooth dongle. The problem isn't the antenna nor the software stack. The same software stack is used for external BT devices. The problem is the built in bluetooth uses a very limited UART interface and it lacks DMA and the bandwidth to support high quality streamed audio. Can't fix that with software.

  • Hi there,


    I have used an external bluetooth dongle for my RPi ZeroW and I get the exact same behaviour as with the onboard. Connection drops after a few seconds or after playback starts.


    Thanks.

  • Disabled the build-in BCM2835 BT controller in the config.txt


    Found a "Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)" Stick under my couch! Is working now, YEAH!

    This solves my problem. I tested first an older BT 3 dongle which works better than the internal one. But with the BT 4.0 Cambridge Silicon Radio with CSR8510 A10 for 4 € the dropouts away. But there are only 10 cm between my sender and receiver. Maybe I will try sometime a headset and walk around.


    I fiddel sometime around with the tips from Raspberry Pi 3 + UART/Bluetooth issues - YouTube

    In order to get the UART run reliable. But no success.


    Maybe someone is smarter an get the internal bt run stable.