LED (VFD) Displays in LibreELEC

  • I had an eventful weekend, busy start to the week, and will be travelling for the rest of the week. There's a slim window this evening to test and then PR something, but no promises (sorry).

  • Just posting this in case anyone else makes the same mistake.


    I'd been having problems with my install of LE and decided to wipe it and set up a new one. I'm using kszaq's 8.2.2.3 release and decided to stick with it as I'd got everything working on it. Everything went fine until I tried to get the VFD working again, as installing the driver stubbornly kept producing

    Code
    1. Open device failed.
    2. : No such file or directory

    errors despite using the vfd.conf file that had worked before. After getting frustrated for a few hours I found The Coolest's post on page 7 and decided to try downloading the dtb's attached, even though I thought I had the right one already (ethernet and wifi were working fine).

    Switched the dtb and Boom, the vfd works. I must have managed to download one without the generic entry that's needed.


    Many thanks to The Coolest for his work here.

  • @The Coolest My device is Zoomtak Upro based on S912.

    Controller chip if FD628. Extracted from stock android image dts is attached.I suppose the node for FD628 driver is:

    m1-vfd {

    compatible = "amlogic,m1-vfd";

    dev_name = "m1-vfd.0";

    status = "okay";

    vfd_stb_pin = <0x35 0x49 0x0>;

    vfd_clk_pin = <0x35 0x47 0x0>;

    vfd_data_pin = <0x35 0x48 0x0>;

    };


    Is it correct that the configuration file should contain

    vfd_gpio_clk='1,73,0'

    vfd_gpio_dat='1,71,0'

    vfd_gpio_stb='1,72,0'


    The rest in config file I hope to find experimenting. Do you have better proposal?
    dts.txt

    Edited once, last by Ico747 ().


  • The link to download the DTB no longer works. Been struggling for days trying other ways to get the correct DTB. I need to fix my display and my remote (getting errors when trying to capture keys, found out the old DTB I have is also to blame for this).


    Is there a working link available? Else, can you please share the file again?

  • @The Coolest


    Can see analyze this dtb.img pls? It's my own dump from my TAP1 1G box because I've been struggling to get LCD working properly with arthur-liberman's vdf.conf (lcd stays all messed up)


    Pls help me

    Files

    • dtb.zip

      (28.51 kB, downloaded 73 times, last: )
  • samura Hi,


    I've spent a long time trying to figure out the way the Tap1 display works. A user spent a while trying to help me, but eventually he gave up.

    I'll send you a PM with some instructions, but I can't guarantee that I will be able to make it work correctly without an actual device to do my testing on.

  • Hi~

    My device is Krizer S912 3/16g model, and it has HBS658 Chip.

    Please let me know how to revive my clock display.

    I attached dtb an dts.

    Thanks.

    Files

    • dtb-dts.zip

      (22.32 kB, downloaded 60 times, last: )
  • onexzero


    Could you please post the full brand and model? A link to the device would be useful.

    The pin configuration is identical to the m9-pro-u2c-x-vfd.conf, so I would suggest you try that first and let me know if it works properly or not.

    Thanks for fast reply.

    I'll try tonight with that vfd.conf.

    Please refer here -> Krizer - Creating a smart world


    Android 7.1.2

    Octa-Core, 64 Bit, ARM Cortex-A53, CPU frequency 2.0GHz

    Penta core ARM Mali-T820

    DDR 2GB,3GB / Flash 16GB

    USB HIGH SPEED 2.0

    WIFI 2.4Ghz / 5Ghz BT 4.0

    HDMI 1.3 / 1.4 / 2.0

    Support 4K

  • onexzero Thanks.

    From the looks of it, the vfd.conf I suggested should work just fine.

    The display looks identical, and so does the DTB configuration.

    Please let me know if it works, and I'll update the file in the repository to include the U5X+S as well.

  • Sorry for my noobism, i tried to copy it from dev/system/ but i cannot copy it for some reason. Is there any other way ?