LibreELEC 8.2.3 on raspberry pi 3 - UPnP faster than Samba

  • Hello guys,

    so I am running latest stable LibreELEC 8.2.3 on a Rpi3. Using 16gb SanDisk class 10 sd card. No issues at all. Bought mpeg2 and VC1 codes, installed and running. BUT when I try to play a 25-35 GB mkv - here comes the issues.

    I know they are a lot of changes on the Samba implementation, but believe me - I have tried many options.

    So the issue is - when I play a bigger FHD mkv file 35GB, it lags, buffers and etc. File added through manual SAMBA path. File stored on Zyxel NSA325v2 NAS. Both Rpi3 and NAS are connected to 1GB LAN.

    Thing is - when I play the same MKV through upnp - NO ISSUES - runs smooth. Issue is you cannot use scrappers via upnp.

    I am using LibreELEC also on a Amlogic S912 box (H96+ pro) where I do not have any issues at all with Samba. Android Box is 1gb eth, and the Rpi3 is 100mbit.

    But still 100mbit should be sufficient and it plays quite well via upnp. I am out of ideas. Tried to update the samba deamon on my Zyxel NAS, as it is 3.5.6, and it supports SMB1 only, but SMB2 wont help with speed I guess.

    Any ideas?

  • Thanks mate!

    Installed LibreELEC-RPi2.arm-9.0-Milhouse-20180124210321-#01 t24-g0290120.tar - > miracle - streaming now all MKVs w/o any issue. I guess it`s related to the samba chunk sizes, probably the latest stable ver 8.2.3 has a different samba client configuration than the new ones.

    But now it`s all okay, thanks again!

  • Hi smp,

    is there a way to get the SMB chunk size fixed in the latest stable 8.2.3 LibreELEC, as the 9.0 is as expected... causing me some other troubles...

    Let me know if there is a fork like that.


  • is there a way to get the SMB chunk size fixed in the latest stable 8.2.3 LibreELEC, as the 9.0 is as expected... causing me some other troubles...

    No, but we're aware of the issue and the fix being used by RPi 9.0 builds, and will consider it for any future 8.2.x update.

  • Thank you milhouse!

    In fact, your builds are quite stable for me... the issue I got is with a subtitles plugin that downloads subtitles archived with RAR commercial license, and it seems that Kodi 18 removed support for this archive... so it`s very annoying, I wish I`d could pay for using rar in Kodi. Apparently Kodi 17 does not have that issue, I guess unrar works there.

    Found unrar but only for openelec. But anyway - i will stay with 9.0 build, cause I like it, and handle the subtitles topic somehow in another way.

    P.S. any ideas about the unrar topic?

    That`s what is happening:

    18:21:45.114 T:1410331536 NOTICE: *** ('test .rar', 'saving')

    18:21:45.615 T:1410331536 NOTICE: *** (u'/storage/.kodi/userdata/addon_data/service.subtitles.unacs/temp/test.rar',)

    18:21:45.619 T:1943298064 ERROR: Extract, No archive given

    18:21:45.686 T:1410331536 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--


    Error Type: <type 'exceptions.IndexError'>

    Error Contents: list index out of range

    Traceback (most recent call last):

    File "/storage/.kodi/addons/service.subtitles.unacs/", line 231, in <module>

    subs = Download(params["ID"],params["link"],params["filename"])

    File "/storage/.kodi/addons/service.subtitles.unacs/", line 146, in Download

    if xbmcvfs.exists(subtitle_list[0]):

    IndexError: list index out of range

    -->End of Python script error report<--

  • You are the man! Testing ASAP and will let you know. If I can confirm this working than this can be a good RC for 8.2.4 probably...

  • Hello smp,

    thanks for your support! I installed -> LibreELEC-RPi2.arm-8.2.2.img.gz then -> LibreELEC-RPi2.arm-8.2.3-smb-64k.tar via update folder

    So here are the results, in a nutshell - did not work, i.e starts 35 mkv test.BluRay.REMUX.AVC.DTS-HD.MA.7.1

    Buffers 20-40 seconds, runs smooth for 20 seconds and then stutter - audio is passthrough to receiver - audio gets lost + video stutter.

    Tried with and without:

    LibreELEC:~ # vcgencmd codec_enabled MPG2


    LibreELEC:~ # vcgencmd codec_enabled WVC1


    Same result.

    Updated to latest LibreELEC-RPi2.arm-9.0-Milhouse-20180125214619-#0125-g3a70864 and video is up & running. But then I got this very very annoying problem, where Kodi 18 can not unrar the subtitles I download. It seems that in Kodi 18 support for RAR archives with commercial license is removed. So plugin downloads the subtitle but then can not load it. I see that this issue has been around since some months. For OpenElec there is an unrar tool which solves some of it, but does not work on Libre.

    But it works like a charm in Kodi 17... so I am now stuck in catch 22:

    - I can have perfect video on FHD very big MKVs, but no subtitles in [email protected] 9.x or

    - I can have subtitles services but can not watch bigger files in [email protected] 8.x

    I have tried to update the Samba version of my Zyxel NAS (NSA325v) cause it`s running 3.5.6 an old Samba version limited to SMB1, but I doubt that SMB2 will fix it honestly.

    Any ideas what I can do with the "unrar" story? And again, thanks for your efforts! Seems that something else beside increasing the SMB chunk has been changed in Kodi 18 to smoothen the playback. For the record, tested also NFS protocol, same result. My Rpi3 and NAS are both wired.

  • What puzzles me is the following. I am experiencing the very same issues like this user here -> PI 2 extremely poor performance video playback

    He just restarted his NAS and voila, it was all working.

    Some background:

    - I have a Zyxel NAS NSA325v2. Samba version was 3.5.6. I upgraded it to 3.6.25

    - I have a Linksys WRT1900ACS. It was running Chaos 15.05 and I upgraded it to LEDE Reboot 17.01.4 r3560-79f57e422d

    Did not make any difference :(

    What is mostly strange it that I can play smoothly all videos via uPnP. I tried OpenELEC, LibreELEC, and all Kodi 17 based versions cannot play big video files (30-40gb) via SAMBA.

    But with latest LibreELEC 9.x it all works fine!

    All my devices are hard wired, the NAS is 1gb, the routher is 1gb, the Rpi3 is 100mb.

    I am really out of any ideas. I tried the custom 8.2.3 build with 64k smb chunk size but still no good luck via Samba.

    Any ideas guys?

  • Пробва ли да конфигурираш (и) NFS на NAS-a, Веляне, вместо SAMBA? :)

    • Official Post


    Keep it in plain English please, so we can all can read it.

    But yes, an attempt with using NFS instead of SMB would be interesting. I've been using NFS for years without serious glitches.

  • It was deliberately,

    pleasant to find an old acquaintance here suddenly... :)

    Apologies, though.

    If NFS setup delivers up to the expectations,

    it'll be a workaround, after all, but it has to be tested, then - consider wholistic solution migration to NFS(v4) and LE 9.0...

  • А, стига, бе! :)) Привет

    Now in english, yep, tried it all. Same damn result, NFS, Samba, all not working. smp even build a LibreELEC 8.2.3 with smb chunk size fixed 64k, but still did not make the difference... Upgraded my samba daemon on my NAS, upgraded WRT1900ACS from CC to LEDE, still the same. I was thinking that`s a NAS issue, but streaming samba from my windows 10 PC deliver the same stuttering result... could be something in my network, but then Kodi 18 works flawlessly.

    With LibreELEC 9.0 and Kodi 18 - no issues at all. The main issue there is that subsunacs/subsab (the bulgarian subtitle plugin) does not work with .rar subtitles archived with rar commercial license. In Kodi 18 this was removed.

    So now I am back to running LibreELEC 8.2 ARM on my H96+ pro box (Amlogic S912) and I can tell you - it`s frakin killing it - 1GB ETH - all very fast, stable, no issues at all. Only issue is with the famous u-boot problem that the box has, but I can live with that (power off with remote cannot power on with remote).

    So that`s my main "no go" with Rpi3 and Libre 9.x now...

    There seems to be NO FIX for this weird situation else than handle subtitles unraring manually. There is unrar plugin, but works only for OpenELEC... :(

  • Hello guys,

    thought that would be helpful to share my experience so far. Got some hints from ChimeyJimmey to adjust advancedsettings.xml. In fact it turned out I was using Kodi`s default cache which is 20MB.

    So I tried all kind of settings, right now I am running with this config in advancedsettings.xml






    So this is almost 140MB of cache, which requires as per Kod`s wiki x3 the amount of RAM, i.e. 140MB of cache requires 420MB of RAM.

    Then there is the other thing. Found an old post from Milhouse where he explains:

    The default in OpenELEC for the Pi2 is 256MB.

    I've found that when running the GUI at 1080 with high colour depth and higher quality fanart/imageres settings in advancedsettings.xml, gpu_mem=320 is necessary to eliminate resource issues.

    So I set my gpu mem to 320:

    LibreELEC:~/.kodi/userdata # vcgencmd get_mem gpu


    At the end now the Rpi3 has 688 MB memory left (420MB of it can be used for cache) leaving 286MB for Kodi which is... well... tight.

    Anyway - now all the stutter and lag is gone, even when streaming 40GB mkv files from my NAS.

    I guess that my memorysize is not ideal, but I will have to tweak it to get to the lowest workable for my box and network.

    Anyway - wanted you to know - now it`s solved!

    p.s. It`s interesting what the change to default cache is in Kodi 18, I guess the same? Then it`s interesting why in Kodi 18 I do not have any issues, even do not have to create advancedsettings.xml to increase cache and increase gpu mem... let`s see.

  • Default cache in Kodi 18 is the same as Kodi 17. However the videoplayer in Kodi 18 has been heavily modified since Kodi 17, and may now be able to work better with lower or unstable bandwidth.

  • Thanks for the info! Is gpu_mem=320 still the choice to go for FHD?

    How much MB of RAM is good enough for Kodi 17 and libreelec under Rpi3?