s905 - hdmi handshake /color space problem with older TVs

  • thank you


    you're right,

    in version LibreELEC-S905.arm-8.0-8.0.2e

    works the entry in

    the autostart.sh

    Mecool M8S Pro+

    Philips 37PFL8404H

  • I borrowed some kernel commits from Sam (OSMC) that supposedly fix RGB mode for Philips TVs. Please test.

    Thanks for keeping an eye out for updates on this nasty issue.


    Updated, tested, and sadly got the pinkish-green colors again on my Philips TV. :(

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • My problem are not exactly the same but maybe something relate to RGB patch.


    I have a nexbox a95x-A1 and I connect it to a dvi monitor with an hdmi to dvi adapter.


    All the versions prior to 8.1.5 have a good color rendering.
    Since version 8.1.5 the display is pink /purple.

    I found in 8.1.5 changelog: "revert all RGB-related changes (this needs to be investigated further)"


    So for my usage, some reverted RGB changes were good for sure !


    I don't use any force rbg command just a clean install.


    I made some test with 3 monitors (2 Dell and Philipps) and same behavior.



    Just a question is there a way to force hmi hotplug ? Just to test because I have a monitor witch displays no hdmi signal.

  • Would it be an option to use 2 adapters, HDMI -> DVI and DVI -> HDMI ?

    I read on another thread that DVI only supports RGB...

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

  • Fredouye It's been reported that DVI mode does not work correctly in latest builds and this will be fixed in 8.2.1.2. I will also try to find out if it's possible to force DVI mode.

  • This build sounds very promising :)


    I updated and had the pink screen just after reboot, but it went back to normal after echoing 1 to /sys/class/amhdmitx/amhdmitx0/output_rgb !

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

  • Well, I spoke too soon :(

    Pink/green went back after a few minutes...strange thing is that echoing 1 to /sys/class/amhdmitx/amhdmitx0/output_rgb once again makes the issue disapear...


    Here's what dmesg shows when running the command :

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

  • Fredouye and everyone else: please try this build:

    LibreELEC-S905.arm-8.2-devel-20171213185420-r26471-gc91652d.tar


    This one tries to stick to DVI mode if you set output_rgb to "1".

    working!! Have nice normal colours instead of pink screen first time since 8.0.2e , I have no sound now though, this something to do with device tree? I have installed to nand, read something about this a bit back!!! Fix one problem have another, wish I hadn't installed to nand!!

  • One more test build to test, please set output_rgb parameter to 1 and check the colours:

    LibreELEC-S905.arm-8.2-devel-20171213220136-r26471-gc91652d.tar

    Sadly, wrong colors after a few minutes in the main menu.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • Many thanks for your effort.

    The handshake bug is fixed (with build 20171213185420)



    echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb

    is that what you mean with "please set output_rgb parameter to 1"

    Mecool M8S Pro+

    Philips 37PFL8404H

    Edited 4 times, last by Harmonia ().

  • Hi kszaq


    with the latest test build (20171213220136), from times to times I get a 1 second black screen, but no more pink/green colors.

    This is not perfect, but definitely usable :)


    I'm going to try the previous build you posted yesterday and report.

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

  • mmpp Can you please post dmesg collected a moment after colours change?

    RMLT

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test