media_build compile error [solved]

  • Hi there,


    I know, this is not really a libreelec issue, but I know, here are some dvbt heroes, so maybe someone can help me!


    So short story:

    I've got an August DVBt210 Stick connected to my Ubuntu 14.04 (3.13.*)

    Since this kernel does not support this dvbt stick out of the box I have to use media_build to generate the neccessary modules! This worked for my last used kernel "3.13.0-107.154". So sadly, I'm a little paranoid, and because of this Meltdown and Spectre issues, I've done a kernel upgrade to kernel "3.13.0-139.188". An now I've to complie media_build again and ran in following compile error:

    Meanwhile, I tried several things, but nothing works, I can eliminate the error in 'uvc_video_decode_meta' (it seem to be just a trace log, But there is still the compile abort.


    Is anyone familar with that? Maybe someone has a workaround, or some hints... Ideas are very welcome...


    Thanks for help,

    WebEye


    PS: Upgrading the system is at the moment not possible.

  • Ok,


    I've got some news, but ran into the next issue, maybe this is more clear for you!


    What I've done:

    While compiling "media_build", I don't use

    linux-media-LATEST.tar.bz2

    but

    linux-media-2017-12-28-201b56737f4e.tar.bz2


    with this I was able to compile "media_build" without error! So with the next Reboot , the stick was successful identified as

    'Mygica T230 DVB-T/T2/C' but was not registered to any firmware


    Additional information:

    I copied all firmwares from

    dvb-firmwares.tar.bz2

    to /lib/firmwares and /usr/lib/firmwares, no luck!


    So here are some dmesg:

    latest successfull boot:

    cat dmesg

    cat dmesg | grep 'dvb\|si2168\|si2157'


    current boot:

    cat dmesg

    cat dmesg | grep 'dvb\|si2168\|si2157'


    hopefully someone can help, I've got no clue!


    Thanks,

    WebEye


    PS: I realized that the si2168 module was not compiled, probably this is the problem!

    The post was edited 1 time, last by WebEye ().