Coowell V5 Libreelec NAND install failed (SOLVED)

  • Hello Everybody,:)


    I am the owner of this android stick. is has 1 gb ram 8 gb rom

    on the MB is printed:

    X10-S905X_1.1

    2016-08-01

    TRAMX

    AMLOGIC S905X

    3AE12 ram?

    D9PXV ram?


    The Coowell V5 has one USB slot and one slot for miro sd cards.

    The USB I have to use for Awireless keyboard or mouse

    Libreelec runs fine from 32 gb TF card but I would like to install it to internal NAND memory so I can use the card slot (the only one) so I can play media from the card.

    But this is not possible if LE is installed on the card

    The only DTB file that works is gxl_p212_1g_nand.dtb but after installtointernal I remove the TF card reset the Coowell en ony get a black screen.

    I suspect the DTB is wrong but is there anybody who can give me A tip to solve this problem or the right DTB ?

    I hope my english is readable!

    Greetings Herman

  • Herman,


    have a look here. You probably need the Device Tree with the _slowemmc-suffix.

    Cheers,


    chessplayer



    Formerly: Intel Atom, Dockstar/Pogoplug (headless PVR Server)

    Production: Wetek Play, RPi3, Cubietruck (headless PVR Server), Nvidia Shield client, XBOX ONE Tuner, Sundtek Media TV Sticks

    Experimental: Various AMLogic S905X (W) devices

  • Hallo Chessplayer,

    I cannot find _slowemmc-suffix file in the link

    The links given are dead

    I have included A picture of my mem chips maybe this wil help

    Greetings Herman:)


    Edited once, last by Hermankodi ().

  • Hello Compos,

    I have found the files

    But I get this error so the sloweemc does not work for me

    login as: root

    [email protected]'s password:

    ##############################################

    # LibreELEC #

    # LibreELEC – Just enough OS for KODI #

    ##############################################


    LibreELEC (community): 8.2.2.2 (S905.arm)

    LibreELEC:~ # installtointernal

    This script will erase BOOT, SYSTEM, DATA and DTB on your device

    and install LE that you booted from SD card/USB drive.


    It will create a backup of device tree and recovery partition on your boot media.


    The script does not have any safeguards!


    Type "yes" if you know what you are doing or anything else to exit: yes

    Formatting SYSTEM partition...The file /dev/system does not exist and no size was specified.


    I have also tried the other two files:

    gxl_p212_1g.dtb same error

    gxl_p212_1g_nand.dtb runs but on removing TF card and reset same error as in my first post (Black screen



    Greetings Herman

    Edited once, last by Hermankodi ().

  • Hello KSZAQ,

    I did as you told me but still only A black screen.

    The method I use boot

    install to internal

    system reboots

    install to internal

    reboot.

    shutdown LE

    remove TF card and replace power plug

    Black screen

    When i replace the TF card LE boots but the coolwell logo screen is gone


    I have included a txt file containing the output in Putty

    If someone have time and are willing to put some effort in it to take a look I will be grateful

    Greetings Herman


    installtointernal log.txt

    Edited once, last by Hermankodi ().

  • Hello Everybosy,


    I have been trying to install to nand but it keeps failing.

    When you install LE tot nand is the original logo (COOWELL in my case) overwritten?

    when I try to boot from nand I only get a black screen.

    When I run the installtointernal script the android is already gone.

    could that be the problem?

    Or s it possible the nand chip is the problem?

    The maker is micron Technology.

    Would it be possible to put the LE file in the recovery dir from android an reboot to recovery to install LE?

    I am hoping for A tip how to succesfully put LE on nand.

    Greetings Herman:)

  • The original logo is not overwritten, only partitions mentioned in the script, i.e. dtb, system, boot and data.


    Black screen should not happen, if dtb is not written successfully, your box should hang on boot logo, not before it.


    The only thing that could help is log from serial console when black screen happens.

  • Hello ,

    Can I conclude LE is not written to the place.?!?

    Is the DTB to blame or must I look somewhere else for the problem?

    I am a beginner at Linux, so could/would you inform me how to get the log from the serial console?

    Is there A place on the net or in this forum where I can learn more about linux?


    Greetings Herman

    And A happy new year to everybody on this very interesting forum.

    Edited once, last by Hermankodi ().

  • Let's try to make this work by a workaround:

    1. Install Android 7 on your box - it should be available as it's S905X unless the manufacturer stopped existing or doesn't release firmware at all.
    2. With Android 7 on NAND, remove dtb.img from SD card with LE and boot LE.
    3. If LE boots, run installtointernal. Now it should boot from internal without a black screen.


    NB: if you don't have Android 7 on NAND, above won't work.

  • Hello KSZAQ,


    I don't think Coowell had released android 7 for this stick.

    The only firmware I could find Was at GearBest.

    I have found another FW I could install on the stick and I believe it is for A mxq box ,it is called aml_mxq_add_boot_systemui.

    I will try to find a FW that installs on my Coowell V5 and try your workaround.

    I have two more questions.

    I hope you can point me in the right direction.

    Where can I find the installtointernal on the LE card.

    I can take a look why it is overwriting the boot logo and

    how can I extract compare the DTB.IMG from android and LE?

    I hope I can edit the DTB.IMG and saving the file.

    But first I try to find android 7 and try your workaround

    Greetings Herman:)

  • Hello Bubblegum57,

    Yes I have but could not find any android 7 fw that works for me.

    I do have found a tool

    CustomizationTool_setup_v2.0.10

    i wil take a look at this tool

    Thanks so far

  • Where can I find the installtointernal on the LE card.

    I can take a look why it is overwriting the boot logo

    To locate any command use which, e.g. which installtointernal. I guarantee that the script doesn't overwrite the boot logo.

    how can I extract compare the DTB.IMG from android and LE?

    I hope I can edit the DTB.IMG and saving the file.

    Device tree on your device is located at /dev/dtb, you can use dtc tool to convert dtb into readable dts. Keep in mind that there will be many differences in device tree as your device has Marshmallow and my build use Nougat kernel.


    I believe the issue is that device tree is not written correctly to internal partition when running the script. It's always been a mistery to me what has to be done to allow writing to /dev/dtb as sometimes it works and sometimes it doesn't. There is no documentation whatsoever that would say how to do this.


    Here's another thing I'd like you to try, that is a modified installtointernal script. Please try the following:

    1. Run LE from SD card as you always do.
    2. Execute these commands to try a modified script:
    Code
    wget https://kszaq.libreelec.tv/s905/8.2/test/installtointernal_test20171231
    chmod +x installtointernal_test20171231
    ./installtointernal_test20171231
  • Hello ZSZAQ,

    Here is what I have done:

    first reset my coowell and installed a Fresh copy of the Coowell v% firmware.

    Made connection and set the time an language.

    Now I have made A fresh LE sd card Using LibreELEC-S905.arm-8.2-8.2.2.2.img

    I have resettet the stick using the resetbuton and the powercable

    LE boots.

    Reset once and booted into LE

    Leave the devicename unchanged logged into my network

    enable SSH and samba

    made the regionalsettings (dutch)

    And the time settings

    made backup of the settings

    rebooted LE

    start putty

    logged in did followed your instructions

    yes

    Do you want to copy your user data to internal data partition?

    n

    Would you like to reboor now [y/N] =>y

    no coowell logo

    LE boot

    run ./installtointernal_test20171231 again

    yes

    Do you want to copy your user data to internal data partition?

    n

    Would you like to reboot now [y/N] =>y

    first removed the sd card and then y

    LE shuts down

    again only a black screen:(

    Greetings Herman:)

  • I will try to find if any of my boxes uses NAND (most of them have eMMC) and see if I can reproduce the issue. But let me do this next year. ;)

  • Hello KSZAG,

    Thanks for your help.

    The people I have invited for this last evening of 2017 will arrive so I have go ofline and start downing some beer.

    one more thing

    After I made the LE install sd I have replaced dtb.img with gxl_p212_1g_nand.dtb (renaming it to dtb.img):!:

    Happy new year Herman:)