MPEG codec not enabling

  • I have four Rpi devices, three RPi2 and one RPi3. When I first switched to LibreElec, I tested the MPEG codec to see if I would need to add my key's or not, and the results on the first couple were enabled, so I never added the key's.


    After a bit of use, I started to realized that the voice and video would start to get out of sync on the main media RPi (an RPi3 device). I decided to test it for the codec and it came back disabled, so I added the keys for that particular devices.


    Even after adding in the key's, the voice and video get out of sync. I test, and the codec comes back as disabled. Other than putting the codes in the config.txt file, I'm not sure what else I need to do to get the voice/video back in sync. Any suggestions?


    Thanks.


    Daryl

  • Are you sure you have the right key for that pi? Each key is unique to one raspberry pi. If you have 4 pis then it is easy to mix them up.

  • Are you sure you have the right key for that pi? Each key is unique to one raspberry pi. If you have 4 pis then it is easy to mix them up.

    Are you sure you have the right key for that pi? Each key is unique to one raspberry pi. If you have 4 pis then it is easy to mix them up.

    That was my first thought as well, so I went through each pi and verified the CPU serial number with the MPG2 code. Three of the four pi's show that mpeg is enabled, however, the fourth, and the one that I use the most, mpeg is still disabled. I even rebuilt the pi just to ensure that it was a good build, and to ensure that I had the correct key with the correct cpu serial number. Still disabled.


    Any other thoughts?


    Thank you.


    Daryl

  • It's either a typo or the key doesn't work, in which case you need to contact the Pi Foundation.

  • It's either a typo or the key doesn't work, in which case you need to contact the Pi Foundation.

    Its not a typo, I copied/pasted directly from the email that I received from the Pi foundation. Perhaps the key is invalid. I'll contact the Pi Foundation.


    Thank you


    Daryl

  • Rosede, I have the same problem. My codecs are for sure enabled as per ssh:


    schlazi:~ # vcgencmd codec_enabled MPG2

    MPG2=enabled

    schlazi:~ # vcgencmd codec_enabled WVC1

    WVC1=enabled


    I am using LibreELEC-RPi2.arm-9.0-Milhouse-20180108220058