Raspberry 3 with USB Wifi Stick

  • Hello everybody,


    i have a little problem with my LibreELEC / Tvheadend client.

    The onboard wifi modul on the Rpi 3 is not fast enught to see HD TV.


    So if ordered this WIFI USB Stick: ANEWKODI Wlan Stick 600Mbit/s, 5dBi Antenna, Dualband: Amazon.de: Elektronik


    In the Rpi3 'confi.txt' i have diabled the onboard modul with entry:

    dtoverlay=pi3-disable-wifi


    When i plug the USB Stick on the Rpi 3, LibreELEC identify the Stick in lsusb as

    Bus 001 Device 004: ID 0bda:a811 Realtek Semiconductor Corp.


    When i connect the Wifi Network on the Kodi Frotend, LibreELEC give the folowing Error Message:

    Network Error: Did not receive a reply. Possible causes include: the remote App


    The Stick connect the Network with really good performance but i can't find any entrys at the logs.


    When i connect on the ssh console with connman he give no Error Message and connect.


    But the problem is when i give the Rpi a reboot from the kodi frontend or with ssh,

    in both things LibreELEC lost/forgett the Wifi Settings and the Key.

    So i must re-enter the Settings an the key at each reboot :-/

  • The connection manager stores network profiles via hardware MAC address, and your device is probably configured with 00:00:00:00 so each time you reboot the kernel assigns a new random MAC. This does not match any existing stored profiles, so you need to configure the network (again).


    "dmesg | paste" and share the URL generated to confirm.

  • Hey chewitt,


    here i have a print out of dmeseg it's from my test with OSMC but is have the same problem.

    I think it is the driver for the rtl8812au chipset he can not read the MAC from the EPROM...


  • I had the same problem in the past. My libreelec setup was only able to see the 5ghz channel 36 and 40. So maybe if you set the 5ghz channel in your router to 36 or 40 the problem is solved.

  • That's interesting too but i can see all Networks in the neighborhood 2,4 an 5 ghz.

    But in case the system can not rigster the real MAC Adress from the Chip that is realy strange that wil work with your solution....

    Crazy :)


    But maybe there are a other or newer driver / frimware for the Chipset that i can install or modify?

  • So and here we have the dmesg URL from as test with Rpi2 on LibreELEC 8.2.1

    URUW


  • Code
    1. [ 4.584266] RTL871X: ERROR invalid mac addr:00:00:00:00:00:00, assign random MAC

    Manufacturers can save $$ if they do not acquire a block of MAC addresses that require each chipset to be programmed with a unique identifier. Finding devices with ^ no MAC is an increasing trend among cheap USB wireless devices.


    It's possible to force a specific MAC using udev rules but it's better done via kernel boot params as these are effected when the driver module loads at boot time. Right now I've forgotten how to do it .. I'll need to Google.

  • Thank you chewitt,


    now i have write a driver option file in /etc/modprobe.d/8812au.conf

    Code
    1. options 8812au rtw_initmac="6b:XX:XX:XX:XX"

    but now i can't find the wifi chanels 12/13 on 2,4 ghz and no 5 ghz Networks :-(

    When i remove yet the conf file and reboot the usb wifi will also not find networks on chancel 12/13 on 2,4 ghz band and 5ghz anymore.

  • Code
    1. echo "options cfg80211 ieee80211_regdom=DE” > /storage/.config/modprobe.d/cfg80211.conf

    ^ Do that to set the wireless regulatory domain. It should allow channels 12-13 if allowed in Germany. If not, you have to break the law and set the regulatory domain to somewhere that allows them.

  • Thank You chewitt,


    that's works fine :)

    On LibreElec 8.x, OSMC 2017-10-1, openElex 6.x


    Here are the soloution compared for all that have se same problem with a externl Wifi device that have no MAC adress.


    For Rpi 3 diable the Internal Wifi Module is it necessary to edit the config.txt file:

    Code
    1. mount -o remount,rw /flash
    2. nano /flash/config.txt

    Add at the End: dtoverlay=pi3-disable-wifi


    Code: config.txt
    1. ...
    2. dtoverlay=pi3-disable-wifi

    and Save after a reboot the internal Wifi Module is diabled.


    For the external Wifi Module based on "rtl8812au" Chipset without a MAC Adress:


    1. Give the System the local info for the Wifi add the File "cfg80211.conf" in the directory "modprobe.d"

    LibreElec/openELEC: /storage/.config/modprobe.d/

    OSMC: /etc/modprobe.d/

    Code: cfg80211.conf
    1. options cfg80211 ieee80211_regdom=DE

    2. Set a fix MAC Adress for the device


    Code: 8812au.conf
    1. options 8812au rtw_initmac=xx:xx:xx:xx:xx:xx rtw_ht_enable=1 rtw_cbw40_enable=3


    Now reboot and enjoy :-)