Flirc wasn't working (solved, sort of), now kodi doesn't scrape subfolders

  • This isn't a Flirc issue, and I can't figure out if it's a kodi or LibreElec issue...


    A month ago my Pi3 with kodi (openelec) froze, where I had to do a hard reboot. After that my Harmony Ultimate would not work properly. Kodi no longer responded to the direction keys or the select key. It would back a noise if I pushed the Back button, and would respond to the Page Up and Page down buttons on the screens.


    I downloaded the updated Flirc app and updated the firmware, re-programmed the direction and select buttons, and returned the Flirc to the Pi 3, but the problem still persisted. It's not an issue with the Flirc because it works with kodi on my Windows installation.


    The I upgraded from openelec to Libreelec. That solved the problem for a day or two, but then the problem returned. Maybe there was an update that screwed things up. So I want to go from kodi 17.4 to 17.1, but I can't find LibreElec 8.0.1. Is there no repository with old versions around?


    I already upgraded to LibreElec 8.2.0, but that did not fix the problem. So I want to see if going to 8.0.1 will fix it.

  • As far as LE and Kodi are concerned the Flirc is just a keyboard. Try remapping the remote using Keymap Editor.

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-7.0.3.2
    MythTV Backend w/HDhomerun PRIME

  • Is the keymap Editor in Kodi/LibreElec? I already reprogrammed it with the Flirc app, and it works with other installs of kodi. I'm trying to avoid reinstalling LibreElec and kodi from scratch.

  • Keymap editor is in the Kodi add-on repo. Make sure there are no old(er) custom keymap.xml and keyboard.xml files installed.

  • A debug log will show you what keys are being received.


    The keymap editor is a Kodi add-on.

  • I installed it, but it won't register the buttons that are not already working. Channel Up and down work for Page Up/Page Down, as when I press them it goes back to the "Select the Action to assign a key" window, and assignes a value to each action (in this case, 61568 and 61569).

  • I wiped my install and went to 8.2.0.1 fresh. Still problems. The wrong buttons are mapped. I'm going to do a fresh install of 8.0.1. If that doesn't work, I will go back to OpenElec.

  • FLIRC doesn't use lirc or in kernel decoding so none of the stuff from the Infrared Remotes wiki page applies here.


    But "RPi freezing" could indicate a marginal power supply or too high overclock setting in which case all kinds of strange things can happen. I'd start looking into that first.


    so long,


    Hias

  • My Pi is not overclock, and the power supply is fine.


    So the Flirc still wouldn't work properly, so I installed the latest version of Openelec. Same problem, so I tried the Flirc with kodi on my Surface Pro ad it worked. So I put it back in the Pi and suddenly the remote worked properly. I would have stayed with Openelec, but for whatever reason, kodi would not scan folders that have sub-folders. So my movies would scan into the library since they are in the root of Movies, but none of my TV Shows got scanned because each series is in its own folder.


    Thus I moved back to LibreElec. Same problem with the Flirc, and same solution with trying it in m Surface. However, this time I cannot add an sources. On the Aeon Nox skin, I go to the home screen and select Files sub-menu under Videos, then Add Videos, on the Add Video Source box, I select Browse, then Add network location, Windows network (SMB) protocol, Browse, navigate to my NAS, and select the Media folder. When I hit Select and Error window pops up saying "File exists". What does this mean? I can't even go into that folder to select a sub folder because of that error. No matter what folder I select, i get this error.


    Has anyone seen this problem before? What is going on and how do I fix it?


    I've decided that once I get this damn thing working again, I am going to image it onto a second microSD card so that the next time something breaks, I can just pop in the backup card and avoid the headaches.

  • it has been my understanding that usb and ethernet on the pi use the same controller. if you're having problems with only the pi and its on ethernet and usb i would guess the controller failed. are they still 35usd? if so it wouldn't be too much too get a new board to test with you have everything else already. if its not the board then you have one for libreelec and one for another project. may not be what you want to hear but its what i would do if the same happened to me.

  • I already have a second Pi3 that I plan on using for RetroPi. It's never been used. I put the microSD card in it that has the LibreElec install, and it's the same problem. I cannot add a source and get the "File exists" error. I re-imaged the microSD with the previous version of LibreElec, and the same thing happened regardless of which Pi3 I used.


    Maybe I need to find a better media program, because kodi never seems to work correctly. Any suggestions?

  • Openelec is not supported here. Two choices:


    openelec forums

    kodi forums

    install libreelec


    OK, make that 3.


    Thread will now be closed as a new topic would have demanded a new thread anyway.