Problems installing 8.2 x64 generic

  • Hi,


    I've been trying to get the 8.2.0 x64 generic installed on a couple of machines.


    First machine wouldn't install properly for an hour and a half then finally worked after another flash the usb image/install cycle.


    Thought it must have been some bad flashing of the usb or install to hard disk for the previous 90 minutes.


    been trying for a couple of hours to install on a different machine this morning with initially the same usb image then different usb stick and reflashing then multiple install attempts to the machines hard disk.


    All have the same problems -


    Cannot install addons - E.G try to change the skin by "get more" but instead of a list of downloads nothing happens - just goes back to previous screen.

    Same for all addons.

    Can't browse shares to my main synology box.

    Can't restore a backup - it goes through the motions and reboots but doesn't restore anything.


    I CAN see this machine on the network and access it's chares - hence being able to copy over a backup file to it.

    I can also browse to other libreelec machines on the network.


    It's like the installer isn't working properly.


    In the kodi log I see lots of lines like:


    09:40:57.620 T:139977665009408 DEBUG: CAddonDatabase: SELECT repo.id FROM repo .. took 0 ms

    09:40:57.620 T:139977665009408 DEBUG: CAddonDatabase: no valid repository matching ''

    09:40:57.620 T:139977665009408 ERROR: GetDirectory - Error getting addons://all/


    09:40:59.660 T:139977631438592 ERROR: GetDirectory - Error getting


    09:41:00.824 T:139978265652544 ERROR: GetDirectory - Error getting addons://sources/

    09:41:00.824 T:139978265652544 ERROR: CGUIMediaWindow::GetDirectory(addons://sources/) failed


    09:43:00.922 T:139978265652544 ERROR: Window Translator: Can't find window videolibrary

    09:43:00.967 T:139978265652544 ERROR: Control 1000 in window 13001 has been asked to focus, but it can't



    10:35:46.209 T:139860788682048 INFO: ADDON: cpluff: 'Could not read plug-in directory /storage/.kodi/addons: No such file or directory'

    10:35:46.242 T:139860788682048 INFO: ADDON: cpluff: 'Could not read plug-in directory /usr/lib/kodi/addons: No such file or directory'

    10:35:47.346 T:139859972847360 WARNING: CSkinInfo: failed to load skin settings



    Trying to restore:


    11:04:23.683 T:139860788682048 DEBUG: ------ Window Deinit (FileBrowser.xml) ------

    11:04:23.703 T:139860523419392 ERROR: ## LibreELEC Addon ## oe::copy_file ## SOURCE: /storage/backup/libreelec8.2freshbackup.tar, DEST: /storage/.restore/libreelec8.2freshbackup.tar

    11:04:23.704 T:139860523419392 ERROR: None

    11:04:23.704 T:139860523419392 DEBUG: DialogProgress::Open called



    Anyone got any ideas?


    Cheers!

  • A few hours on, still no further :(


    Anyone out there offer any ideas?


    Noticed in the usb key install log that during the makefs bit it was giving some block messages?


    Does this mean that the ssd in the computer is on its way out, had similar messages during the install on the other computer so is that ssd on the way out too?

  • Thanks chewitt.


    Making headway..


    So please try this to duplicate:


    Fresh install of a generic x86 box from usb.


    goto settings/interface settings/skin/get more - pressing enter nothing happens!!


    Go back to main menu

    Select addons from the menu

    video addons - it will say none installed so right arrow to enter add on browser

    choose install from repository

    all repositories - it won't do anything

    now choose kodi addon repos

    the spinner comes up then a list of addons

    go back via ..

    now choose all repos again BUT NOW they are all there!


    now go back to main menu and goto settings and try to download a new skin again - IT NOW WORKS!


    this all has same probs with 8.0.2 as well on 2 different intel boxes.



    Is the system the image was created from faulty? Not creating all the required directories?


    Finally managed a restore - had to restore and reboot twice for it to stick?!



    I've uploaded logs to VjGd

  • Some boxes have slow loading network drivers that cause the initial repo update check to fail, which can result in there being "no add-ons in the repo!!!" .. so if it happens again just force refresh the repo and/or add a startup delay to Kodi via LE settings, and all will be fixed.

  • Thanks chewitt.


    That's strange, I still had the same problems with the wait for network set to 20 seconds (it continued after just a couple of seconds). Or do you mean another delay somewhere else?

  • Thanks Jocke, I'll reinstall version 8.2 tonight and do the correct logs.


    BTW I did a fresh install of 7.03 as a test. This had the same problems as 8.x - couldn't find any addons / skins etc until I went into the kodi repository and then the libreelec repository. Network was up..


    Exactly the same as version 8.x.


    This make me think there's a quirk in the way libreelec is installed for intel machines - it's almost like some folders or flags aren't set until you go into kodi repository and then the libreelec repository. (Choosing all repositories yields nothing)


    Now I know about this quirk, it's not a problem but it had me stumped for MANY hours thinking it was corrupt installs or network problems.


    However, any first time users who install libreelec then try to say change the skin or install an addon without first going into each of the repositories (not sure if adding media sources will work) will be stumped wondering why no addons/skins are available/shown to download or nothing happens...


    I would very much like this behaviour to be confirmed but I've seen this on two different machines, multiple versions, many re-installs, 3 different hard disks and 7 usb sticks :)


    I've never noticed this before, but then I've been upgrading and restoring backups not doing fresh installs for the last few years...


    My main problem now is that after getting it going I find that 23.x fps playback is jerky. For that I've started a different thread..