Posts by r4w


    On my MiniMX III (s905), I got 4.2MB/s download (~33Mb/s) over a gigabit fiber and gigabit ethernet connection.
    ARM processor are not very good with encryption... and there is no hardware encryption supported with the kernel (cryptodev) like Intel can do.

    Code
    LibreELEC:~ # ./speedtest_vpn.sh
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
     77  476M   77  368M    0     0  3749k      0  0:02:10  0:01:40  0:00:30 4205k


    According to this whitepaper, :

    • Crypto Engine – AES/AES-XTS block cipher with 128/192/256 bits keys, DES/TDES block cipher, Hardware crypto key-ladder operation and DVB-CSA for transport stream encryption, built-in hardware True Random Number Generator (TRNG), CRC and SHA-1/SHA-2/HMAC SHA engine


    I have to disagree that the processor can't handle properly encryption/decryption using its hardware but I would instead check that the VPN is actually using an AES based algorithm.
    I can't talk about what the kernel supports or less though.


    kszaq is aware of this, so I believe we need just to wait and see if they can fix this. Until then, happy to use NFS from OS.
    I'm not really concerned about the maximum bitrate I can play, as I don't have UHD movies to see just now, but it's possible that Kodi is using more resources to get its internal NFS/SAMBA working.

    140 Mbps is less than 20 MB/sec (17.5 to be precise).
    My wireless connection is at around 180 Mbit (tested with iperf / tcp).
    I'm now using NFS over udp, which goes straight to a single disk (a brand new WD Red 3 TB).
    Anyway, I was using a USB2 stick which performed around 18 MB/sec, so maybe at limit, so I have tested with a USB3 stick (over 40 MB/sec read on a USB3 port with my laptop) and I have to admit that USB is the right choice for UHD and s905x is not the issue here (and yes, I believe somehow the boards are all the same :) )
    I played without issues the 200 and 250 Mbit file.


    I'm surprised that your box based on s905x (like mine) is able to handle the 140 Mbit file. I have tried directly from a USB stick and it was lagging.
    Somewhere I have read that these boxes are all created equal, so that's not true ;)

    mmpp: Unfortunately in my case when I power it off, the led in front of the box goes red for a second and then it goes back to blue and LE restarts from SD, therefore it stays in power on.
    I have reached out to the seller to see if there's a firmware upgrade.
    It's a kind of strange box what I have, I haven't seen many s905x with Wireless AC around yet.


    Can you not use Keymap Editor to map the back button, if the rest of your remote is working already?


    Kodi (7.95.2) doesn't even recognise my buttons are being pressed.


    The back button works as long as the air mouse is disabled, unsure if this is by design then.
    Any other button seems to work (I didn't try the numbers or the Internet explorer button nor the buttons at top Play/Pause/skip track etc).
    I'm doing this at night and to watch a movie I didn't need them but tbh I didn't notice the play/pause one, it's on my list to try it :)

    Kshi: Interesting, it seems it's another manufacturer indeed.


    usb-devices: LFPA
    ls-usb -v: SOQX


    I got it from ebay (cheapest I could find), I guess they all look the same: 2.4GHz Wireless Fly Air Mouse Keyboard Remote For Android PC Smart TV Box MX3 M8


    PS: I have tested all the important buttons and everything seems to work for me.
    I'm wondering if it's normal that the "back" button doesn't work when the air mouse is enabled, but I can live with that.

    Nope, it is not expected. Mine shuts down when told to do so :P
    I don't remember anyone else mention this problem.


    That's odd, but I have just recalled that I may have forgotten to copy the right dtb last time I have upgraded. Could that cause this? Anything else works.
    I'm waiting for my new microsd to upgrade to beta5b.
    Thank you!